# CVE-2026-45414: Decidim: JWT-backed authentication can be replayed across organizations

> Attackers can replay JWTs across tenants to access unauthorized participant data and proposal endpoints in Decidim.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Aug 2026
- **Updated:** 7 Aug 2026
- **Also known as:** GHSA-r3v7-5x4c-c69q

## What is CVE-2026-45414?

CVE-2026-45414 is a high-severity authentication bypass vulnerability in decidim, published on 6 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Decidim is a participatory democracy framework. Prior to 0.31.5 and in 0.32.0.rc1 before 0.32.0.rc2, JWT-backed API authentication is not bound to the organization selected by the current host, allowing a JWT issued for one tenant to be replayed against another tenant’s API to read participantDetails data and reach the proposal.answer mutation path. This issue is fixed in versions 0.31.5 and 0.32.0.rc2.

Weakness: CWE-863 (Incorrect Authorization), CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-45414?

4 open source packages ship an affected version, including decidim.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `decidim` | RubyGems | All versions | 0.31.5 |
| `decidim` | RubyGems | All versions | 0.31.5 |
| `decidim` | RubyGems | From 0.32.0.rc1 | 0.32.0 |
| `decidim` | RubyGems | From 0.32.0.rc1 | 0.32.0 |

## How do I fix CVE-2026-45414?

Upgrade decidim to a fixed version for your release line: 0.31.5 or 0.32.0.

## Is CVE-2026-45414 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45414 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45414 and fix it if it is affected.

What it is: CVE-2026-45414 is a high-severity authentication bypass vulnerability in decidim, published on 6 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45414 exists.

Affected packages and fixed versions:
- decidim (RubyGems): affected all versions; fixed in 0.31.5
- decidim (RubyGems): affected all versions; fixed in 0.31.5
- decidim (RubyGems): affected from 0.32.0.rc1; fixed in 0.32.0
- decidim (RubyGems): affected from 0.32.0.rc1; fixed in 0.32.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45414/ (Markdown: https://insights.sbomify.com/CVE-2026-45414/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45414
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45414
- OSV: https://osv.dev/vulnerability/CVE-2026-45414

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45414/
Summaries are generated and may contain mistakes; the official description above is the record.
