CVE-2026-45415 Decidim: CSV census record endpoints improper authorization
A participant manager can create, alter, or remove census records due to missing administrator authorization checks on CSV endpoints.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-45415?
CVE-2026-45415 is a medium-severity missing authorization vulnerability in decidim, published on 6 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Decidim is a participatory democracy framework. Prior to 0.30.9, from 0.31.0 before 0.31.5, and in 0.32.0.rc1 before 0.32.0.rc2, the /admin/csv_census/census_logs record-management endpoints do not enforce full administrator authorization before rendering or mutating Decidim::Verifications::CsvDatum, allowing a participant manager to create, alter, or remove census records. This issue is fixed in versions 0.30.9, 0.31.5, and 0.32.0.rc2.
Weakness: CWE-862
Which versions are affected by CVE-2026-45415?
6 open source packages ship an affected version, including decidim-verifications.
| Package | Affected | Fixed in |
|---|---|---|
decidim-verifications RubyGems | All versions | 0.30.9 |
decidim-verifications RubyGems | All versions | 0.30.9 |
decidim-verifications RubyGems | From 0.31.0.rc1 | 0.31.5 |
decidim-verifications RubyGems | From 0.31.0.rc1 | 0.31.5 |
decidim-verifications RubyGems | From 0.32.0.rc1 | 0.32.0 |
decidim-verifications RubyGems | From 0.32.0.rc1 | 0.32.0 |
How do I fix CVE-2026-45415?
Upgrade decidim-verifications to a fixed version for your release line: 0.30.9, 0.31.5 or 0.32.0.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-45415 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45415 exists.
Sources
Also known as GHSA-q79h-67vx-m9xg.