# CVE-2026-45415: Decidim: CSV census record endpoints improper authorization

> A participant manager can create, alter, or remove census records due to missing administrator authorization checks on CSV endpoints.

- **Severity:** Medium 6.0 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Aug 2026
- **Updated:** 7 Aug 2026
- **Also known as:** GHSA-q79h-67vx-m9xg

## What is CVE-2026-45415?

CVE-2026-45415 is a medium-severity missing authorization vulnerability in decidim, published on 6 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Decidim is a participatory democracy framework. Prior to 0.30.9, from 0.31.0 before 0.31.5, and in 0.32.0.rc1 before 0.32.0.rc2, the /admin/csv_census/census_logs record-management endpoints do not enforce full administrator authorization before rendering or mutating Decidim::Verifications::CsvDatum, allowing a participant manager to create, alter, or remove census records. This issue is fixed in versions 0.30.9, 0.31.5, and 0.32.0.rc2.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-45415?

6 open source packages ship an affected version, including decidim-verifications.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `decidim-verifications` | RubyGems | All versions | 0.30.9 |
| `decidim-verifications` | RubyGems | All versions | 0.30.9 |
| `decidim-verifications` | RubyGems | From 0.31.0.rc1 | 0.31.5 |
| `decidim-verifications` | RubyGems | From 0.31.0.rc1 | 0.31.5 |
| `decidim-verifications` | RubyGems | From 0.32.0.rc1 | 0.32.0 |
| `decidim-verifications` | RubyGems | From 0.32.0.rc1 | 0.32.0 |

## How do I fix CVE-2026-45415?

Upgrade decidim-verifications to a fixed version for your release line: 0.30.9, 0.31.5 or 0.32.0.

## Is CVE-2026-45415 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45415 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45415 and fix it if it is affected.

What it is: CVE-2026-45415 is a medium-severity missing authorization vulnerability in decidim, published on 6 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45415 exists.

Affected packages and fixed versions:
- decidim-verifications (RubyGems): affected all versions; fixed in 0.30.9
- decidim-verifications (RubyGems): affected all versions; fixed in 0.30.9
- decidim-verifications (RubyGems): affected from 0.31.0.rc1; fixed in 0.31.5
- decidim-verifications (RubyGems): affected from 0.31.0.rc1; fixed in 0.31.5
- decidim-verifications (RubyGems): affected from 0.32.0.rc1; fixed in 0.32.0
- decidim-verifications (RubyGems): affected from 0.32.0.rc1; fixed in 0.32.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45415/ (Markdown: https://insights.sbomify.com/CVE-2026-45415/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45415
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45415
- OSV: https://osv.dev/vulnerability/CVE-2026-45415

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45415/
Summaries are generated and may contain mistakes; the official description above is the record.
