# CVE-2026-45426: Apache Airflow: Log server JWT authorization bypass via Python lstrip() character stripping allows cross-Dag log access

> Authenticated Airflow workers can bypass per-DAG log isolation and read logs from other DAGs due to incorrect JWT validation logic.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2026
- **Updated:** 1 Jun 2026
- **Also known as:** BIT-airflow-2026-45426, ECHO-e9d4-431a-60ba, GHSA-x5wm-j6wh-2834, MINI-3397-3fr4-q47v, PYSEC-2026-174

## What is CVE-2026-45426?

CVE-2026-45426 is a low-severity authentication bypass vulnerability in Apache Airflow, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Exploitation requires the attacker to already be an authenticated Airflow worker holding a valid Log-server JWT issued for at least one Dag. Apache Airflow's Log server authorized JWT tokens against Dag IDs by applying Python's `str.lstrip()` to the requested path segment when verifying the JWT's `sub` claim. `str.lstrip()` strips any of a *set* of characters from the left (not a prefix), so a JWT issued for a Dag named e.g. `dag_a` would authorize log access to any other Dag whose name began with any subset of the characters `{d, a, g, _}` (e.g. `dag_attacker`, `aaaa_target`, `_dag_secret`). Such an authenticated worker could enumerate and read worker logs of other Dags whose names happened to share that character-class prefix, leaking task output and error traces beyond the documented per-Dag isolation boundary. Affects deployments relying on per-Dag log-access scoping (multi-team, shared-executor, shared-worker topologies). Users are advised to upgrade to `apache-airflow` 3.2.2 or later.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-45426?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | From 3.0.0 | 3.2.2 |
| `apache-airflow` | PyPI | From 3.0.0 | 3.2.2 |
| `apache-airflow` | PyPI | From 3.0.0 | 3.2.2 |
| `airflow` | Bitnami | From 3.0.0 | 3.2.2 |

Products: Apache Airflow.

## How do I fix CVE-2026-45426?

Upgrade apache-airflow to 3.2.2 or later.

## Is CVE-2026-45426 being exploited?

There is no known exploitation of CVE-2026-45426 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45426 and fix it if it is affected.

What it is: CVE-2026-45426 is a low-severity authentication bypass vulnerability in Apache Airflow, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45426 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected from 3.0.0; fixed in 3.2.2
- apache-airflow (PyPI): affected from 3.0.0; fixed in 3.2.2
- apache-airflow (PyPI): affected from 3.0.0; fixed in 3.2.2
- airflow (Bitnami): affected from 3.0.0; fixed in 3.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45426/ (Markdown: https://insights.sbomify.com/CVE-2026-45426/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45426
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45426
- OSV: https://osv.dev/vulnerability/CVE-2026-45426

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45426/
Summaries are generated and may contain mistakes; the official description above is the record.
