CVE-2026-45434 Apache OFBiz: Authentication Bypass via Password-Change Logic Flaw Leading to RCE
Attackers can bypass authentication via a password-change flaw to achieve remote code execution in Apache OFBiz.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-45434?
CVE-2026-45434 is a critical authentication bypass vulnerability in Apache Ofbiz, published on 19 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Authentication vulnerability in Apache OFBiz via Password-Change Logic Flaw Leading to Remote Code Execution
This issue affects Apache OFBiz: before 24.09.06.
Users are recommended to upgrade to version 24.09.06, which fixes the issue.
Weakness: CWE-287
Which versions are affected by CVE-2026-45434?
It affects 1 product.
Products include Apache Ofbiz.
How do I fix CVE-2026-45434?
No fix has been published for CVE-2026-45434 yet. Limit exposure of the affected software until one is available.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-45434 being exploited?
There is no known exploitation of CVE-2026-45434 in the wild and no public exploit code.
Other vulnerabilities in Apache Ofbiz
- CVE-2024-45195 Apache OFBiz Forced Browsing
- CVE-2024-32113 Apache OFBiz Path Traversal
- CVE-2024-38856 Apache OFBiz Incorrect Authorization
- CVE-2013-2250 Code injection in n/a
- CVE-2012-3506 Unspecified vulnerability in the Apache Open For Business Project (aka OFBiz) 10.04.x before 10.04.03 has unknown impact and attack vectors.
Sources
Also known as GHSA-qcxg-xcph-9r99.