CVE-2026-45505 Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Jolokia `addNetworkConnector` Discovery Wrapper Bypass
Authenticated attackers can bypass validation to execute arbitrary code on Apache ActiveMQ brokers via crafted Jolokia requests.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-45505?
CVE-2026-45505 is a high-severity code injection vulnerability in Apache Activemq, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ.
Non-parenthesized discovery wrappers such as `masterslave:vm://...,...` and `static:vm://...` incorrectly pass validation allowing bypass of fix in CVE-2026-34197.
Original description from CVE-2026-34197.
Apache ActiveMQ exposes the Jolokia JMX-HTTP bridge at /api/jolokia/ on the web console. The default Jolokia access policy permits exec operations on all ActiveMQ MBeans (org.apache.activemq:*), including BrokerService.addNetworkConnector(String) and BrokerService.addConnector(String). An authenticated attacker can invoke these operations with a crafted discovery UR that triggers the VM transport's brokerConfig parameter to load a remote Spring XML application context using ResourceXmlApplicationContext. Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec(). This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6.
Users are recommended to upgrade to version 5.19.7 or 6.2.6, which fixes the issue.
Which versions are affected by CVE-2026-45505?
13 open source packages ship an affected version, including org.apache.activemq:activemq-all, activemq and org.apache.activemq:activemq-broker. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.activemq:activemq-all Maven | All versions | 5.19.7 |
org.apache.activemq:activemq-all Maven | All versions | 5.19.7 |
org.apache.activemq:activemq-all Maven | From 6.0.0 | 6.2.6 |
org.apache.activemq:activemq-all Maven | From 6.0.0 | 6.2.6 |
activemq Bitnami | All versions | 5.19.7, 6.2.6 |
org.apache.activemq:activemq-broker Maven | All versions | 5.19.7 |
7 more packages
org.apache.activemq:activemq-broker Maven | All versions | 5.19.7 |
org.apache.activemq:activemq-broker Maven | From 6.0.0 | 6.2.6 |
org.apache.activemq:activemq-broker Maven | From 6.0.0 | 6.2.6 |
org.apache.activemq:apache-activemq Maven | All versions | 5.19.7 |
org.apache.activemq:apache-activemq Maven | All versions | 5.19.7 |
org.apache.activemq:apache-activemq Maven | From 6.0.0 | 6.2.6 |
org.apache.activemq:apache-activemq Maven | From 6.0.0 | 6.2.6 |
Products include Apache Activemq, Apache Activemq Broker.
How do I fix CVE-2026-45505?
Upgrade org.apache.activemq:activemq-all to a fixed version for your release line: 5.19.7 or 6.2.6.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-45505 being exploited?
There is no known exploitation of CVE-2026-45505 in the wild and no public exploit code.
Other vulnerabilities in Apache Activemq
Sources
Also known as BIT-activemq-2026-45505, DEBIAN-CVE-2026-45505, GHSA-v853-w46p-fv2h, MINI-5mq9-6qwq-5966, MINI-6wgm-jxfc-5h22, MINI-phq3-5gxq-3wxr and 3 more.