# CVE-2026-45535: DataEase: Stored SQL Injection Vulnerability

> Attackers can inject SQL via dataset variables, allowing unauthorized data access or modification when datasets are viewed.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Jul 2026
- **Updated:** 16 Jul 2026
- **Also known as:** GHSA-pv23-p64m-4pxf

## What is CVE-2026-45535?

CVE-2026-45535 is a high-severity SQL injection vulnerability in dataease, published on 15 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

DataEase is an open source data visualization and analysis tool. Prior to 2.10.23, DataEase SQL-type datasets store attacker-controlled SQL variable defaultValue entries such as ${var} and SqlparserUtils.handleVariableDefaultValue() inserts them with String.replace() without escaping or parameterization, causing stored SQL injection whenever a user with dataset read permission accesses the dataset. This issue is fixed in version 2.10.23.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-45535?


## How do I fix CVE-2026-45535?

No fix has been published for CVE-2026-45535 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-45535 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45535 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45535 and fix it if it is affected.

What it is: CVE-2026-45535 is a high-severity SQL injection vulnerability in dataease, published on 15 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45535 exists.

Affected product: dataease. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45535/ (Markdown: https://insights.sbomify.com/CVE-2026-45535/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45535
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45535
- OSV: https://osv.dev/vulnerability/CVE-2026-45535

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45535/
Summaries are generated and may contain mistakes; the official description above is the record.
