# CVE-2026-45537: OpenSIPS: Global Buffer Overflow in construct_uri

> An attacker can trigger a buffer overflow in OpenSIPS via a long URI username, potentially executing code or altering server routing behavior.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 4 Aug 2026
- **Updated:** 5 Aug 2026
- **Also known as:** GHSA-v7h4-fwrc-c66v, UBUNTU-CVE-2026-45537

## What is CVE-2026-45537?

CVE-2026-45537 is a critical memory corruption vulnerability in opensips, published on 4 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. In versions prior to 3.6.6 and 4.0.0-rc1, the construct_uri() function concatenates multiple URI components (protocol, username, domain, port, params) into a fixed 1024-byte global BSS buffer without any bounds checking. When a routing script calls construct_uri() with an attacker-controlled username, a combined component length exceeding 1024 bytes overflows the buffer, corrupting adjacent global data with attacker-controlled content. The overflow reaches disable_503_translation, a global flag controlling SIP 503 response handling, allowing an attacker to deterministically set the flag via the URI username and alter the server's routing behavior for subsequent messages. Because the same buffer is shared with contact_builder(), the overflow also corrupts that function's data, and without a memory sanitizer the adjacent globals are silently overwritten on every request containing a long username. This issue has been fixed in versions 3.6.6 and 4.0.0-rc1.

Weakness: CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2026-45537?


## How do I fix CVE-2026-45537?

No fix has been published for CVE-2026-45537 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-45537 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45537 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45537 and fix it if it is affected.

What it is: CVE-2026-45537 is a critical memory corruption vulnerability in opensips, published on 4 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45537 exists.

Affected product: opensips. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45537/ (Markdown: https://insights.sbomify.com/CVE-2026-45537/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45537
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45537
- OSV: https://osv.dev/vulnerability/CVE-2026-45537

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45537/
Summaries are generated and may contain mistakes; the official description above is the record.
