CVE-2026-45551 Group-Office: Authenticated Stored XSS in Administrator Context via Arbitrary Cross-User Setting Write
Authenticated users can inject JavaScript into administrator settings, leading to stored XSS and potential privilege escalation in Group-Office.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2026-45551?
CVE-2026-45551 is a medium-severity cross-site scripting vulnerability in Intermesh groupoffice, published on 29 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Group-Office is an enterprise customer relationship management and groupware tool. Prior to 26.0.25, 25.0.100, and 6.8.165, GroupOffice allows authenticated users to persist arbitrary legacy settings for any user_id via index.php?r=core/saveSetting. A separate client-side sink in the email module injects the email_font_size setting directly into JavaScript without escaping. By combining these two issues, any low-privileged authenticated user can overwrite an administrator's email_font_size setting with a JavaScript payload and trigger stored XSS in the administrator's browser when the GroupOffice web client loads views/Extjs3/modulescripts.php. This vulnerability is fixed in 26.0.25, 25.0.100, and 6.8.165.
Which versions are affected by CVE-2026-45551?
How do I fix CVE-2026-45551?
No fix has been published for CVE-2026-45551 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-45551 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45551 exists.
Sources
Also known as GHSA-9w92-p32g-g99p.