{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45551 exists.","fix":"No fix has been published for CVE-2026-45551 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-45551 is a medium-severity cross-site scripting vulnerability in Intermesh groupoffice, published on 29 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-45551 and fix it if it is affected.\n\nWhat it is: CVE-2026-45551 is a medium-severity cross-site scripting vulnerability in Intermesh groupoffice, published on 29 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45551 exists.\n\nAffected product: Intermesh groupoffice. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-45551/ (Markdown: https://insights.sbomify.com/CVE-2026-45551/index.md)","id":"CVE-2026-45551","markdown":"https://insights.sbomify.com/CVE-2026-45551/index.md","name":"CVE-2026-45551","record":{"aliases":["GHSA-9w92-p32g-g99p"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Group-Office groupware","requires_auth":"low_privilege","summary":"Authenticated users can inject JavaScript into administrator settings, leading to stored XSS and potential privilege escalation in Group-Office.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-639","name":"Authorization Bypass Through User-Controlled Key"}],"description":"Group-Office is an enterprise customer relationship management and groupware tool. Prior to 26.0.25, 25.0.100, and 6.8.165, GroupOffice allows authenticated users to persist arbitrary legacy settings for any user_id via index.php?r=core/saveSetting. A separate client-side sink in the email module injects the email_font_size setting directly into JavaScript without escaping. By combining these two issues, any low-privileged authenticated user can overwrite an administrator's email_font_size setting with a JavaScript payload and trigger stored XSS in the administrator's browser when the GroupOffice web client loads views/Extjs3/modulescripts.php. This vulnerability is fixed in 26.0.25, 25.0.100, and 6.8.165.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Group-Office: Authenticated Stored XSS in Administrator Context via Arbitrary Cross-User Setting Write","id":"CVE-2026-45551","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"Roxy-WI: Cross-tenant authorization bypass on /install/* — guest can run Ansible / SSH on every registered server","id":"CVE-2026-45552"},"packages":[],"prev":{"headline":"Roxy-WI: IDOR on PUT /smon/check — any user can rewrite any tenant's monitoring URL/IP/body","id":"CVE-2026-45550"},"products":["groupoffice"],"published":"2026-05-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-29","vendors":["Intermesh"]},"summary":"Authenticated users can inject JavaScript into administrator settings, leading to stored XSS and potential privilege escalation in Group-Office.","url":"https://insights.sbomify.com/CVE-2026-45551/"}