# CVE-2026-45551: Group-Office: Authenticated Stored XSS in Administrator Context via Arbitrary Cross-User Setting Write

> Authenticated users can inject JavaScript into administrator settings, leading to stored XSS and potential privilege escalation in Group-Office.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 29 May 2026
- **Updated:** 29 May 2026
- **Also known as:** GHSA-9w92-p32g-g99p

## What is CVE-2026-45551?

CVE-2026-45551 is a medium-severity cross-site scripting vulnerability in Intermesh groupoffice, published on 29 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Group-Office is an enterprise customer relationship management and groupware tool. Prior to 26.0.25, 25.0.100, and 6.8.165, GroupOffice allows authenticated users to persist arbitrary legacy settings for any user_id via index.php?r=core/saveSetting. A separate client-side sink in the email module injects the email_font_size setting directly into JavaScript without escaping. By combining these two issues, any low-privileged authenticated user can overwrite an administrator's email_font_size setting with a JavaScript payload and trigger stored XSS in the administrator's browser when the GroupOffice web client loads views/Extjs3/modulescripts.php. This vulnerability is fixed in 26.0.25, 25.0.100, and 6.8.165.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-45551?


## How do I fix CVE-2026-45551?

No fix has been published for CVE-2026-45551 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-45551 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45551 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45551 and fix it if it is affected.

What it is: CVE-2026-45551 is a medium-severity cross-site scripting vulnerability in Intermesh groupoffice, published on 29 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45551 exists.

Affected product: Intermesh groupoffice. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45551/ (Markdown: https://insights.sbomify.com/CVE-2026-45551/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45551
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45551
- OSV: https://osv.dev/vulnerability/CVE-2026-45551

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45551/
Summaries are generated and may contain mistakes; the official description above is the record.
