# CVE-2026-45553: NiceGUI: Local file disclosure via Docutils file insertion in ui.restructured_text()

> Attackers can read local server files by injecting Docutils directives into reStructuredText content passed to the NiceGUI framework.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jun 2026
- **Updated:** 3 Jun 2026
- **Also known as:** GHSA-jfrm-rx66-g536, PYSEC-2026-2679

## What is CVE-2026-45553?

CVE-2026-45553 is a high-severity vulnerability in zauberzeug nicegui, published on 2 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NiceGUI is a Python-based UI framework. Prior to version 3.12.0, ui.restructured_text() renders reStructuredText server-side with Docutils without disabling file insertion directives. When a NiceGUI application passes attacker-controlled content to ui.restructured_text(), an attacker can use standard Docutils directives (include, csv-table with :file:, raw with :file:) to read local files readable by the NiceGUI server process. Applications that only pass trusted static strings to ui.restructured_text() are not affected. This issue has been patched in version 3.12.0.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-45553?

3 open source packages ship an affected version, including nicegui.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nicegui` | PyPI | All versions | 3.12.0 |
| `nicegui` | PyPI | All versions | 3.12.0 |
| `nicegui` | PyPI | All versions | 3.12.0 |

## How do I fix CVE-2026-45553?

Upgrade nicegui to 3.12.0 or later.

## Is CVE-2026-45553 being exploited?

There is no known exploitation of CVE-2026-45553 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45553 and fix it if it is affected.

What it is: CVE-2026-45553 is a high-severity vulnerability in zauberzeug nicegui, published on 2 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45553 in the wild and no public exploit code.

Affected packages and fixed versions:
- nicegui (PyPI): affected all versions; fixed in 3.12.0
- nicegui (PyPI): affected all versions; fixed in 3.12.0
- nicegui (PyPI): affected all versions; fixed in 3.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45553/ (Markdown: https://insights.sbomify.com/CVE-2026-45553/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45553
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45553
- OSV: https://osv.dev/vulnerability/CVE-2026-45553

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45553/
Summaries are generated and may contain mistakes; the official description above is the record.
