# CVE-2026-45554: NiceGUI: Unauthenticated log-flood DoS via trailing slash on ESM and per-component resource routes

> Remote attackers can cause denial of service by flooding server logs via unauthenticated requests to specific static asset routes in NiceGUI.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jun 2026
- **Updated:** 2 Jun 2026
- **Also known as:** GHSA-pq7c-x8g4-rvp6, PYSEC-2026-2680

## What is CVE-2026-45554?

CVE-2026-45554 is a medium-severity denial of service vulnerability in zauberzeug nicegui, published on 2 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NiceGUI is a Python-based UI framework. Prior to version 3.12.0, two FastAPI routes that serve per-component static assets in NiceGUI accept a sub-path parameter that may resolve to a directory rather than a file. Requests that resolve to a directory raise an unhandled RuntimeError inside Starlette's FileResponse, which Uvicorn writes to the server log as a full traceback. Because the routes are reachable without authentication, a remote attacker can amplify log volume and consume disk and log-pipeline capacity on any publicly reachable NiceGUI server. This issue has been patched in version 3.12.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-45554?

3 open source packages ship an affected version, including nicegui.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nicegui` | PyPI | All versions | 3.12.0 |
| `nicegui` | PyPI | All versions | 3.12.0 |
| `nicegui` | PyPI | All versions | 3.12.0 |

## How do I fix CVE-2026-45554?

Upgrade nicegui to 3.12.0 or later.

## Is CVE-2026-45554 being exploited?

There is no known exploitation of CVE-2026-45554 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45554 and fix it if it is affected.

What it is: CVE-2026-45554 is a medium-severity denial of service vulnerability in zauberzeug nicegui, published on 2 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45554 in the wild and no public exploit code.

Affected packages and fixed versions:
- nicegui (PyPI): affected all versions; fixed in 3.12.0
- nicegui (PyPI): affected all versions; fixed in 3.12.0
- nicegui (PyPI): affected all versions; fixed in 3.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45554/ (Markdown: https://insights.sbomify.com/CVE-2026-45554/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45554
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45554
- OSV: https://osv.dev/vulnerability/CVE-2026-45554

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45554/
Summaries are generated and may contain mistakes; the official description above is the record.
