CVE-2026-45572 Decidim: HTML content blocks allow stored script execution
Administrators can inject malicious scripts into HTML content blocks, leading to stored XSS execution in visitors' browsers.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-45572?
CVE-2026-45572 is a medium-severity cross-site scripting vulnerability in decidim, published on 6 Aug 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Decidim is a participatory democracy framework. Prior to 0.30.9, from 0.31.0 before 0.31.5, and in 0.32.0.rc1 before 0.32.0.rc2, an administrator with landing-page editing privileges can store arbitrary HTML and JavaScript in an HTML content block, which Decidim::ContentBlocks::HtmlCell#html_content renders without sanitization, causing the script to execute in visitors' browsers. This issue is fixed in versions 0.30.9, 0.31.5, and 0.32.0.rc2.
Weakness: CWE-94
Which versions are affected by CVE-2026-45572?
6 open source packages ship an affected version, including decidim-core.
| Package | Affected | Fixed in |
|---|---|---|
decidim-core RubyGems | All versions | 0.30.9 |
decidim-core RubyGems | All versions | 0.30.9 |
decidim-core RubyGems | From 0.31.0.rc1 | 0.31.5 |
decidim-core RubyGems | From 0.31.0.rc1 | 0.31.5 |
decidim-core RubyGems | From 0.32.0.rc1 | 0.32.0 |
decidim-core RubyGems | From 0.32.0.rc1 | 0.32.0 |
How do I fix CVE-2026-45572?
Upgrade decidim-core to a fixed version for your release line: 0.30.9, 0.31.5 or 0.32.0.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-45572 being exploited?
There is no known exploitation of CVE-2026-45572 in the wild and no public exploit code.
Sources
Also known as GHSA-533c-2vh9-4r86.