{"answers":{"affected":"6 open source packages ship an affected version, including decidim-core.","exploited":"There is no known exploitation of CVE-2026-45572 in the wild and no public exploit code.","fix":"Upgrade decidim-core to a fixed version for your release line: 0.30.9, 0.31.5 or 0.32.0.","what":"CVE-2026-45572 is a medium-severity cross-site scripting vulnerability in decidim, published on 6 Aug 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-45572 and fix it if it is affected.\n\nWhat it is: CVE-2026-45572 is a medium-severity cross-site scripting vulnerability in decidim, published on 6 Aug 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-45572 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- decidim-core (RubyGems): affected all versions; fixed in 0.30.9\n- decidim-core (RubyGems): affected all versions; fixed in 0.30.9\n- decidim-core (RubyGems): affected from 0.31.0.rc1; fixed in 0.31.5\n- decidim-core (RubyGems): affected from 0.31.0.rc1; fixed in 0.31.5\n- decidim-core (RubyGems): affected from 0.32.0.rc1; fixed in 0.32.0\n- decidim-core (RubyGems): affected from 0.32.0.rc1; fixed in 0.32.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-45572/ (Markdown: https://insights.sbomify.com/CVE-2026-45572/index.md)","id":"CVE-2026-45572","markdown":"https://insights.sbomify.com/CVE-2026-45572/index.md","name":"CVE-2026-45572","record":{"aliases":["GHSA-533c-2vh9-4r86"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Decidim participatory democracy","requires_auth":"high_privilege","summary":"Administrators can inject malicious scripts into HTML content blocks, leading to stored XSS execution in visitors' browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Decidim is a participatory democracy framework. Prior to 0.30.9, from 0.31.0 before 0.31.5, and in 0.32.0.rc1 before 0.32.0.rc2, an administrator with landing-page editing privileges can store arbitrary HTML and JavaScript in an HTML content block, which Decidim::ContentBlocks::HtmlCell#html_content renders without sanitization, causing the script to execute in visitors' browsers. This issue is fixed in versions 0.30.9, 0.31.5, and 0.32.0.rc2.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Decidim: HTML content blocks allow stored script execution","id":"CVE-2026-45572","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":6,"n_references":2,"next":{"headline":"Decidim: Push subscriptions can be abused for server-side requests","id":"CVE-2026-45573"},"packages":[{"ecosystem":"RubyGems","fixed":["0.30.9"],"introduced":["0"],"last_affected":[],"package":"decidim-core","purl":null,"source":"GHSA-533c-2vh9-4r86"},{"ecosystem":"RubyGems","fixed":["0.30.9"],"introduced":["0"],"last_affected":[],"package":"decidim-core","purl":"pkg:gem/decidim-core","source":"GHSA-533c-2vh9-4r86"},{"ecosystem":"RubyGems","fixed":["0.31.5"],"introduced":["0.31.0.rc1"],"last_affected":[],"package":"decidim-core","purl":null,"source":"GHSA-533c-2vh9-4r86"},{"ecosystem":"RubyGems","fixed":["0.31.5"],"introduced":["0.31.0.rc1"],"last_affected":[],"package":"decidim-core","purl":"pkg:gem/decidim-core","source":"GHSA-533c-2vh9-4r86"},{"ecosystem":"RubyGems","fixed":["0.32.0"],"introduced":["0.32.0.rc1"],"last_affected":[],"package":"decidim-core","purl":null,"source":"GHSA-533c-2vh9-4r86"},{"ecosystem":"RubyGems","fixed":["0.32.0"],"introduced":["0.32.0.rc1"],"last_affected":[],"package":"decidim-core","purl":"pkg:gem/decidim-core","source":"GHSA-533c-2vh9-4r86"}],"prev":{"headline":"go-git: Crafted repositories may modify main and submodule .git directories","id":"CVE-2026-45571"},"products":["decidim"],"published":"2026-08-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-07","vendors":["decidim"]},"summary":"Administrators can inject malicious scripts into HTML content blocks, leading to stored XSS execution in visitors' browsers.","url":"https://insights.sbomify.com/CVE-2026-45572/"}