{"answers":{"affected":"6 open source packages ship an affected version, including decidim-core.","exploited":"There is no known exploitation of CVE-2026-45573 in the wild and no public exploit code.","fix":"Upgrade decidim-core to a fixed version for your release line: 0.30.9, 0.31.5 or 0.32.0.","what":"CVE-2026-45573 is a medium-severity server-side request forgery vulnerability in decidim, published on 6 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-45573 and fix it if it is affected.\n\nWhat it is: CVE-2026-45573 is a medium-severity server-side request forgery vulnerability in decidim, published on 6 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-45573 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- decidim-core (RubyGems): affected all versions; fixed in 0.30.9\n- decidim-core (RubyGems): affected all versions; fixed in 0.30.9\n- decidim-core (RubyGems): affected from 0.31.0.rc1; fixed in 0.31.5\n- decidim-core (RubyGems): affected from 0.31.0.rc1; fixed in 0.31.5\n- decidim-core (RubyGems): affected from 0.32.0.rc1; fixed in 0.32.0\n- decidim-core (RubyGems): affected from 0.32.0.rc1; fixed in 0.32.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-45573/ (Markdown: https://insights.sbomify.com/CVE-2026-45573/index.md)","id":"CVE-2026-45573","markdown":"https://insights.sbomify.com/CVE-2026-45573/index.md","name":"CVE-2026-45573","record":{"aliases":["GHSA-2g9c-vf8h-prxx"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Decidim participatory democracy framework","requires_auth":"low_privilege","summary":"Authenticated users can trigger server-side requests to arbitrary HTTPS endpoints via unvalidated push subscriptions when VAPID delivery is enabled.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Decidim is a participatory democracy framework. Prior to 0.30.9, from 0.31.0 before 0.31.5, and in 0.32.0.rc1 before 0.32.0.rc2, when VAPID delivery is enabled, the notification subscription flow stores a client-supplied push endpoint without validating that it belongs to an approved push service, and SendPushNotification later passes that endpoint to WebPush.payload_send, allowing an authenticated user to create stored, mostly blind server-side requests to arbitrary reachable HTTPS endpoints. This issue is fixed in versions 0.30.9, 0.31.5, and 0.32.0.rc2.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Decidim: Push subscriptions can be abused for server-side requests","id":"CVE-2026-45573","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":6,"n_references":2,"next":{"headline":"epa4all-client: TLS Certificate Validation Disabled in Production","id":"CVE-2026-45574"},"packages":[{"ecosystem":"RubyGems","fixed":["0.30.9"],"introduced":["0"],"last_affected":[],"package":"decidim-core","purl":null,"source":"GHSA-2g9c-vf8h-prxx"},{"ecosystem":"RubyGems","fixed":["0.30.9"],"introduced":["0"],"last_affected":[],"package":"decidim-core","purl":"pkg:gem/decidim-core","source":"GHSA-2g9c-vf8h-prxx"},{"ecosystem":"RubyGems","fixed":["0.31.5"],"introduced":["0.31.0.rc1"],"last_affected":[],"package":"decidim-core","purl":null,"source":"GHSA-2g9c-vf8h-prxx"},{"ecosystem":"RubyGems","fixed":["0.31.5"],"introduced":["0.31.0.rc1"],"last_affected":[],"package":"decidim-core","purl":"pkg:gem/decidim-core","source":"GHSA-2g9c-vf8h-prxx"},{"ecosystem":"RubyGems","fixed":["0.32.0"],"introduced":["0.32.0.rc1"],"last_affected":[],"package":"decidim-core","purl":null,"source":"GHSA-2g9c-vf8h-prxx"},{"ecosystem":"RubyGems","fixed":["0.32.0"],"introduced":["0.32.0.rc1"],"last_affected":[],"package":"decidim-core","purl":"pkg:gem/decidim-core","source":"GHSA-2g9c-vf8h-prxx"}],"prev":{"headline":"Decidim: HTML content blocks allow stored script execution","id":"CVE-2026-45572"},"products":["decidim"],"published":"2026-08-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-08","vendors":["decidim"]},"summary":"Authenticated users can trigger server-side requests to arbitrary HTTPS endpoints via unvalidated push subscriptions when VAPID delivery is enabled.","url":"https://insights.sbomify.com/CVE-2026-45573/"}