# CVE-2026-45573: Decidim: Push subscriptions can be abused for server-side requests

> Authenticated users can trigger server-side requests to arbitrary HTTPS endpoints via unvalidated push subscriptions when VAPID delivery is enabled.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Aug 2026
- **Updated:** 8 Aug 2026
- **Also known as:** GHSA-2g9c-vf8h-prxx

## What is CVE-2026-45573?

CVE-2026-45573 is a medium-severity server-side request forgery vulnerability in decidim, published on 6 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Decidim is a participatory democracy framework. Prior to 0.30.9, from 0.31.0 before 0.31.5, and in 0.32.0.rc1 before 0.32.0.rc2, when VAPID delivery is enabled, the notification subscription flow stores a client-supplied push endpoint without validating that it belongs to an approved push service, and SendPushNotification later passes that endpoint to WebPush.payload_send, allowing an authenticated user to create stored, mostly blind server-side requests to arbitrary reachable HTTPS endpoints. This issue is fixed in versions 0.30.9, 0.31.5, and 0.32.0.rc2.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-45573?

6 open source packages ship an affected version, including decidim-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `decidim-core` | RubyGems | All versions | 0.30.9 |
| `decidim-core` | RubyGems | All versions | 0.30.9 |
| `decidim-core` | RubyGems | From 0.31.0.rc1 | 0.31.5 |
| `decidim-core` | RubyGems | From 0.31.0.rc1 | 0.31.5 |
| `decidim-core` | RubyGems | From 0.32.0.rc1 | 0.32.0 |
| `decidim-core` | RubyGems | From 0.32.0.rc1 | 0.32.0 |

## How do I fix CVE-2026-45573?

Upgrade decidim-core to a fixed version for your release line: 0.30.9, 0.31.5 or 0.32.0.

## Is CVE-2026-45573 being exploited?

There is no known exploitation of CVE-2026-45573 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45573 and fix it if it is affected.

What it is: CVE-2026-45573 is a medium-severity server-side request forgery vulnerability in decidim, published on 6 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45573 in the wild and no public exploit code.

Affected packages and fixed versions:
- decidim-core (RubyGems): affected all versions; fixed in 0.30.9
- decidim-core (RubyGems): affected all versions; fixed in 0.30.9
- decidim-core (RubyGems): affected from 0.31.0.rc1; fixed in 0.31.5
- decidim-core (RubyGems): affected from 0.31.0.rc1; fixed in 0.31.5
- decidim-core (RubyGems): affected from 0.32.0.rc1; fixed in 0.32.0
- decidim-core (RubyGems): affected from 0.32.0.rc1; fixed in 0.32.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45573/ (Markdown: https://insights.sbomify.com/CVE-2026-45573/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45573
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45573
- OSV: https://osv.dev/vulnerability/CVE-2026-45573

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45573/
Summaries are generated and may contain mistakes; the official description above is the record.
