CVE-2026-45574 epa4all-client: TLS Certificate Validation Disabled in Production

High 8.1 Published Updated

An attacker can intercept sensitive SOAP traffic and credentials by presenting invalid TLS certificates due to disabled validation in the epa4all-client library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2026-45574?

CVE-2026-45574 is a high-severity vulnerability in com.oviva.telematik epa4all-client, published on 26 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

epa4all-client is the Java Client for epa4all / ePA 3.0 in the Telematik Infrastruktur. Prior to 1.2.2, an attacker on the network path between the ePA service and the Konnektor can present any TLS certificate (self-signed, expired, wrong CN) and intercept all SOAP traffic. This includes patient identifiers (KVNR), SMC-B card operations (authentication, signing), document content, and credential exchanges. This vulnerability is fixed in 1.2.2.

Weakness: CWE-295

Which versions are affected by CVE-2026-45574?

2 open source packages ship an affected version, including com.oviva.telematik:epa4all-client.

PackageAffectedFixed in
com.oviva.telematik:epa4all-client MavenAll versions1.2.2
com.oviva.telematik:epa4all-client MavenAll versions1.2.2

How do I fix CVE-2026-45574?

Upgrade com.oviva.telematik:epa4all-client to 1.2.2 or later.

Is CVE-2026-45574 being exploited?

There is no known exploitation of CVE-2026-45574 in the wild and no public exploit code.

Sources

Also known as GHSA-5hhf-xmfx-4vvr.

Is CVE-2026-45574 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free