{"answers":{"affected":"2 open source packages ship an affected version, including com.oviva.telematik:epa4all-client.","exploited":"There is no known exploitation of CVE-2026-45574 in the wild and no public exploit code.","fix":"Upgrade com.oviva.telematik:epa4all-client to 1.2.2 or later.","what":"CVE-2026-45574 is a high-severity vulnerability in com.oviva.telematik epa4all-client, published on 26 May 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-45574 and fix it if it is affected.\n\nWhat it is: CVE-2026-45574 is a high-severity vulnerability in com.oviva.telematik epa4all-client, published on 26 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-45574 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.oviva.telematik:epa4all-client (Maven): affected all versions; fixed in 1.2.2\n- com.oviva.telematik:epa4all-client (Maven): affected all versions; fixed in 1.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-45574/ (Markdown: https://insights.sbomify.com/CVE-2026-45574/index.md)","id":"CVE-2026-45574","markdown":"https://insights.sbomify.com/CVE-2026-45574/index.md","name":"CVE-2026-45574","record":{"aliases":["GHSA-5hhf-xmfx-4vvr"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Java Telematik client","requires_auth":"none","summary":"An attacker can intercept sensitive SOAP traffic and credentials by presenting invalid TLS certificates due to disabled validation in the epa4all-client library.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"epa4all-client is the Java Client for epa4all / ePA 3.0 in the Telematik Infrastruktur. Prior to 1.2.2, an attacker on the network path between the ePA service and the Konnektor can present any TLS certificate (self-signed, expired, wrong CN) and intercept all SOAP traffic. This includes patient identifiers (KVNR), SMC-B card operations (authentication, signing), document content, and credential exchanges. This vulnerability is fixed in 1.2.2.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"epa4all-client: TLS Certificate Validation Disabled in Production","id":"CVE-2026-45574","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"epa4all-client: Improper Verification of Cryptographic Signature","id":"CVE-2026-45575"},"packages":[{"ecosystem":"Maven","fixed":["1.2.2"],"introduced":["0"],"last_affected":[],"package":"com.oviva.telematik:epa4all-client","purl":null,"source":"GHSA-5hhf-xmfx-4vvr"},{"ecosystem":"Maven","fixed":["1.2.2"],"introduced":["0"],"last_affected":[],"package":"com.oviva.telematik:epa4all-client","purl":"pkg:maven/com.oviva.telematik/epa4all-client","source":"GHSA-5hhf-xmfx-4vvr"}],"prev":{"headline":"Decidim: Push subscriptions can be abused for server-side requests","id":"CVE-2026-45573"},"products":["epa4all-client"],"published":"2026-05-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-27","vendors":["com.oviva.telematik","oviva-ag"]},"summary":"An attacker can intercept sensitive SOAP traffic and credentials by presenting invalid TLS certificates due to disabled validation in the epa4all-client library.","url":"https://insights.sbomify.com/CVE-2026-45574/"}