# CVE-2026-45574: epa4all-client: TLS Certificate Validation Disabled in Production

> An attacker can intercept sensitive SOAP traffic and credentials by presenting invalid TLS certificates due to disabled validation in the epa4all-client library.

- **Severity:** High 8.1 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 May 2026
- **Updated:** 27 May 2026
- **Also known as:** GHSA-5hhf-xmfx-4vvr

## What is CVE-2026-45574?

CVE-2026-45574 is a high-severity vulnerability in com.oviva.telematik epa4all-client, published on 26 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

epa4all-client is the Java Client for epa4all / ePA 3.0 in the Telematik Infrastruktur. Prior to 1.2.2, an attacker on the network path between the ePA service and the Konnektor can present any TLS certificate (self-signed, expired, wrong CN) and intercept all SOAP traffic. This includes patient identifiers (KVNR), SMC-B card operations (authentication, signing), document content, and credential exchanges. This vulnerability is fixed in 1.2.2.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-45574?

2 open source packages ship an affected version, including com.oviva.telematik:epa4all-client.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.oviva.telematik:epa4all-client` | Maven | All versions | 1.2.2 |
| `com.oviva.telematik:epa4all-client` | Maven | All versions | 1.2.2 |

## How do I fix CVE-2026-45574?

Upgrade com.oviva.telematik:epa4all-client to 1.2.2 or later.

## Is CVE-2026-45574 being exploited?

There is no known exploitation of CVE-2026-45574 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45574 and fix it if it is affected.

What it is: CVE-2026-45574 is a high-severity vulnerability in com.oviva.telematik epa4all-client, published on 26 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45574 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.oviva.telematik:epa4all-client (Maven): affected all versions; fixed in 1.2.2
- com.oviva.telematik:epa4all-client (Maven): affected all versions; fixed in 1.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45574/ (Markdown: https://insights.sbomify.com/CVE-2026-45574/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45574
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45574
- OSV: https://osv.dev/vulnerability/CVE-2026-45574

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45574/
Summaries are generated and may contain mistakes; the official description above is the record.
