# CVE-2026-45577: Neotoma: Unauthenticated Inspector/API access via reverse-proxy loopback auth bypass

> Attackers can bypass authentication to access the Inspector and API when Neotoma is deployed behind a reverse proxy using loopback sockets.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2026
- **Updated:** 29 May 2026
- **Also known as:** GHSA-5cvp-p7p4-mcx9

## What is CVE-2026-45577?

CVE-2026-45577 is a medium-severity authentication bypass vulnerability in markmhendrickson neotoma, published on 29 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Neotoma provides versioned records that persist across agent runs. From 0.6.0 to before 0.11.1, Neotoma can treat public reverse-proxied requests as local when the app receives them over a loopback socket and no Bearer token is present. In affected deployments, the REST auth middleware can resolve unauthenticated requests as the local development user, making the hosted Inspector and related API surface reachable without credentials. This vulnerability is fixed in 0.11.1.

Weakness: CWE-306 (Missing Authentication for Critical Functionality), CWE-288 (Authentication Bypass Using an Alternate Path or Channel)

## Which versions are affected by CVE-2026-45577?

2 open source packages ship an affected version, including neotoma.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `neotoma` | npm | From 0.6.0 | 0.11.1 |
| `neotoma` | npm | From 0.6.0 | 0.11.1 |

## How do I fix CVE-2026-45577?

Upgrade neotoma to 0.11.1 or later.

## Is CVE-2026-45577 being exploited?

There is no known exploitation of CVE-2026-45577 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45577 and fix it if it is affected.

What it is: CVE-2026-45577 is a medium-severity authentication bypass vulnerability in markmhendrickson neotoma, published on 29 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45577 in the wild and no public exploit code.

Affected packages and fixed versions:
- neotoma (npm): affected from 0.6.0; fixed in 0.11.1
- neotoma (npm): affected from 0.6.0; fixed in 0.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45577/ (Markdown: https://insights.sbomify.com/CVE-2026-45577/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45577
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45577
- OSV: https://osv.dev/vulnerability/CVE-2026-45577

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45577/
Summaries are generated and may contain mistakes; the official description above is the record.
