CVE-2026-45579 DIRAC: RCE in RequestManager due to eval on untrusted input
An authenticated attacker can execute arbitrary code via Python eval in DIRAC RequestManager, leading to full system compromise and credential theft.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-45579?
CVE-2026-45579 is a critical code injection vulnerability in DIRACGrid DIRAC, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
DIRAC is an interware, meaning a software framework for distributed computing. Prior to versions 8.0.79, 9.0.22, and 9.1.10, the RequestManagementSystem/Service/ReqManagerHandler.py export_getRequestCountersWeb function passes an authenticated caller-controlled groupingAttribute to RequestManagementSystem/DB/RequestDB.py getRequestCountersWeb. An unrecognized value is resolved against the Request object and evaluated as Python code, allowing a crafted dunder attribute expression to reach operating-system functions and execute commands as the account running the DIRAC services. Successful exploitation can expose dirac.cfg, database passwords, stored proxies, and tokens, fully compromise the DIRAC system, and allow alteration of local log evidence. This issue is fixed in versions 8.0.79, 9.0.22, and 9.1.10.
Weakness: CWE-95
Which versions are affected by CVE-2026-45579?
7 open source packages ship an affected version, including dirac and DIRAC.
| Package | Affected | Fixed in |
|---|---|---|
dirac PyPI | From 6 | 8.0.79, 9.0.22, 9.1.10 |
dirac PyPI | From 6 | 8.0.79 |
dirac PyPI | From 8.1.0a1 | 9.0.22 |
dirac PyPI | From 9.1.0 | 9.1.10 |
DIRAC PyPI | From 6 | 8.0.79 |
DIRAC PyPI | From 8.1.0a1 | 9.0.22 |
1 more packages
DIRAC PyPI | From 9.1.0 | 9.1.10 |
How do I fix CVE-2026-45579?
Upgrade dirac to a fixed version for your release line: 8.0.79, 9.0.22 or 9.1.10.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-45579 being exploited?
There is no known exploitation of CVE-2026-45579 in the wild and no public exploit code.
Sources
Also known as GHSA-9jpv-c7p4-997x, PYSEC-2026-3462.