{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45616 exists.","fix":"No fix has been published for CVE-2026-45616 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-45616 is a medium-severity cross-site scripting vulnerability in givanz Vvveb, published on 15 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-45616 and fix it if it is affected.\n\nWhat it is: CVE-2026-45616 is a medium-severity cross-site scripting vulnerability in givanz Vvveb, published on 15 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45616 exists.\n\nAffected product: givanz Vvveb. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-45616/ (Markdown: https://insights.sbomify.com/CVE-2026-45616/index.md)","id":"CVE-2026-45616","markdown":"https://insights.sbomify.com/CVE-2026-45616/index.md","name":"CVE-2026-45616","record":{"aliases":["GHSA-39gc-pjv5-4w4p"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Vvveb CMS","requires_auth":"low_privilege","summary":"Stored XSS in the Vvveb CMS post editor allows attackers to escalate privileges and potentially execute code.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Vvveb is a powerful and easy to use CMS with page builder to build websites, blogs or ecommerce stores. Prior to 1.0.8.3,  This vulnerability is fixed in 1.0.8.3.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Vvveb: Stored XSS in Posts allows privilege escalation via post editor","id":"CVE-2026-45616","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"LiquidJS: ReDoS via Quadratic Backtracking in `strip_html` Filter Regex","id":"CVE-2026-45617"},"packages":[],"prev":{"headline":"mouse07410/asn1c: 1-byte Heap Out-of-Bounds Read in `INTEGER_decode_oer` via Malformed OER Payload","id":"CVE-2026-45615"},"products":["Vvveb"],"published":"2026-05-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-15","vendors":["givanz"]},"summary":"Stored XSS in the Vvveb CMS post editor allows attackers to escalate privileges and potentially execute code.","url":"https://insights.sbomify.com/CVE-2026-45616/"}