CVE-2026-45617 LiquidJS: ReDoS via Quadratic Backtracking in `strip_html` Filter Regex

High 7.5 Published Updated

An attacker can cause severe CPU exhaustion and event-loop blocking in Node.js applications using LiquidJS by sending crafted input to the strip_html filter.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-45617?

CVE-2026-45617 is a high-severity denial of service vulnerability in harttle liquidjs, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

LiquidJS is a Shopify/GitHub Pages compatible template engine written in pure JavaScript. In versions 10.25.7 and below, the built-in strip_html filter uses a regex containing four flawed lazy-quantified alternatives, leading to ReDoS via quadratic backtracking. When the input contains many <script, <style, or <!-- opener tokens without matching closers, the V8 regex engine performs O(N²) backtracking, blocking the Node.js event loop. A single ~350 KB request ('<script'.repeat(50000)) stalls the process for ~10 seconds; cost grows quadratically with input size. The default memoryLimit: Infinity does not bound regex CPU, and even when configured strip_html only charges str.length to the limit — the regex itself runs unbounded. A single unauthenticated request containing crafted untrusted input can cause severe event-loop blocking and CPU amplification that saturates Node.js workers while bypassing memoryLimit protections. This issue has been fixed in version 10.26.0.

Weakness: CWE-1333

Which versions are affected by CVE-2026-45617?

2 open source packages ship an affected version, including liquidjs.

PackageAffectedFixed in
liquidjs npmAll versions10.26.0
liquidjs npmAll versions10.26.0

How do I fix CVE-2026-45617?

Upgrade liquidjs to 10.26.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-45617 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45617 exists.

Sources

Also known as ECHO-25d0-5f90-77b5, GHSA-r7g9-xpmj-5fcq, MINI-7ffw-67vx-4q5v, MINI-hf2w-6fq8-pw27, MINI-j548-8jwf-465h.

Is CVE-2026-45617 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free