# CVE-2026-45617: LiquidJS: ReDoS via Quadratic Backtracking in `strip_html` Filter Regex

> An attacker can cause severe CPU exhaustion and event-loop blocking in Node.js applications using LiquidJS by sending crafted input to the strip_html filter.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2026
- **Updated:** 18 Jun 2026
- **Also known as:** ECHO-25d0-5f90-77b5, GHSA-r7g9-xpmj-5fcq, MINI-7ffw-67vx-4q5v, MINI-hf2w-6fq8-pw27, MINI-j548-8jwf-465h

## What is CVE-2026-45617?

CVE-2026-45617 is a high-severity denial of service vulnerability in harttle liquidjs, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

LiquidJS is a Shopify/GitHub Pages compatible template engine written in pure JavaScript. In versions 10.25.7 and below, the built-in strip_html filter uses a regex containing four flawed lazy-quantified alternatives, leading to ReDoS via quadratic backtracking. When the input contains many <script, <style, or <!-- opener tokens without matching closers, the V8 regex engine performs O(N²) backtracking, blocking the Node.js event loop. A single ~350 KB request ('<script'.repeat(50000)) stalls the process for ~10 seconds; cost grows quadratically with input size. The default memoryLimit: Infinity does not bound regex CPU, and even when configured strip_html only charges str.length to the limit — the regex itself runs unbounded.  A single unauthenticated request containing crafted untrusted input can cause severe event-loop blocking and CPU amplification that saturates Node.js workers while bypassing memoryLimit protections. This issue has been fixed in version 10.26.0.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-45617?

2 open source packages ship an affected version, including liquidjs.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `liquidjs` | npm | All versions | 10.26.0 |
| `liquidjs` | npm | All versions | 10.26.0 |

## How do I fix CVE-2026-45617?

Upgrade liquidjs to 10.26.0 or later.

## Is CVE-2026-45617 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45617 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45617 and fix it if it is affected.

What it is: CVE-2026-45617 is a high-severity denial of service vulnerability in harttle liquidjs, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45617 exists.

Affected packages and fixed versions:
- liquidjs (npm): affected all versions; fixed in 10.26.0
- liquidjs (npm): affected all versions; fixed in 10.26.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45617/ (Markdown: https://insights.sbomify.com/CVE-2026-45617/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45617
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45617
- OSV: https://osv.dev/vulnerability/CVE-2026-45617

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45617/
Summaries are generated and may contain mistakes; the official description above is the record.
