{"answers":{"affected":"2 open source packages ship an affected version, including postcss. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45623 exists.","fix":"Upgrade postcss to 8.5.12 or later.","what":"CVE-2026-45623 is a high-severity path traversal vulnerability in postcss, published on 27 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-45623 and fix it if it is affected.\n\nWhat it is: CVE-2026-45623 is a high-severity path traversal vulnerability in postcss, published on 27 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45623 exists.\n\nAffected packages and fixed versions:\n- postcss (npm): affected all versions; fixed in 8.5.12\n- postcss (npm): affected all versions; fixed in 8.5.12\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-45623/ (Markdown: https://insights.sbomify.com/CVE-2026-45623/index.md)","id":"CVE-2026-45623","markdown":"https://insights.sbomify.com/CVE-2026-45623/index.md","name":"CVE-2026-45623","record":{"aliases":["CLSA-2026-1784856189","CLSA-2026-1784856448","CLSA-2026-1784943201","CLSA-2026-1785117457","CLSA-2026-1785117465","CLSA-2026-1785204444","CLSA-2026-1785204576","CLSA-2026-1785291205","CLSA-2026-1790190302","CLSA-2026-1790200920","CLSA-2026-1792164377","DEBIAN-CVE-2026-45623","ECHO-3dd3-3c70-3964","GHSA-6g55-p6wh-862q","MINI-6544-3ccf-3334","MINI-8j67-f2c6-q9xh","MINI-98r2-vhf5-44pp","MINI-ggwg-939q-9r2p","MINI-mg84-rwc9-42mj","MINI-rw43-5r5j-mrfr","MINI-v7f6-9845-6j55","MINI-xcgc-526c-5m6p","ROOT-APP-NPM-CVE-2026-45623","UBUNTU-CVE-2026-45623"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PostCSS library","requires_auth":"none","summary":"Attackers can read arbitrary local files and cause denial of service by injecting malicious sourceMappingURL comments into CSS processed by PostCSS.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"postcss","vendor":"postcss"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"PostCSS takes a CSS file and provides an API to analyze and modify its rules by transforming the rules into an Abstract Syntax Tree. In versions 8.5.11 and prior, the PreviousMap parses the /*# sourceMappingURL=PATH */ comment from any CSS string passed to process() and dereferences PATH against the local filesystem with no scheme, allowlist, or traversal check. An attacker who controls the CSS input can cause the host process to read any file readable by Node and leak the first ~10 bytes of its content through the resulting JSON.parse SyntaxError message. The bug also yields a precise file-existence oracle and a controllable-read primitive that may be combined with large-file targets for DoS. The behaviour is triggered with PostCSS's default options — no from, no map, no plugins required — and is therefore reachable from any pipeline that runs untrusted CSS through PostCSS (CMS themes, user-uploaded styles, browser-extension/userstyle processors, build pipelines for third-party packages, blog comment renderers, etc.). This issue has been fixed in version 8.5.12.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"PostCSS: Arbitrary file read and information disclosure via attacker-controlled sourceMappingURL in CSS comments","id":"CVE-2026-45623","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"ImageMagick: Heap Buffer Over-Read of a 4 bytes in distort operation.","id":"CVE-2026-45624"},"packages":[{"ecosystem":"npm","fixed":["8.5.12"],"introduced":["0"],"last_affected":[],"package":"postcss","purl":null,"source":"GHSA-6g55-p6wh-862q"},{"ecosystem":"npm","fixed":["8.5.12"],"introduced":["0"],"last_affected":[],"package":"postcss","purl":"pkg:npm/postcss","source":"GHSA-6g55-p6wh-862q"}],"prev":{"headline":"Vvveb: Unauthenticated reflected XSS in public product return form via customer_order_id","id":"CVE-2026-45622"},"products":["postcss"],"published":"2026-07-27","related":[{"cvss_score":6.3,"headline":"PostCSS: incomplete fix of GHSA-6g55-p6wh-862q — attacker-controlled sourceMappingURL reads arbitrary .map files when `from` is unset","id":"CVE-2026-69153","kev_date_added":null,"published":"2026-08-03"},{"cvss_score":5.3,"headline":"PostCSS line return parsing error","id":"CVE-2023-44270","kev_date_added":null,"published":"2023-09-29"},{"cvss_score":5.3,"headline":"Regular Expression Denial of Service (ReDoS)","id":"CVE-2021-23382","kev_date_added":null,"published":"2021-04-26"},{"cvss_score":5.3,"headline":"Regular Expression Denial of Service (ReDoS)","id":"CVE-2021-23368","kev_date_added":null,"published":"2021-04-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-27","vendors":["postcss"]},"summary":"Attackers can read arbitrary local files and cause denial of service by injecting malicious sourceMappingURL comments into CSS processed by PostCSS.","url":"https://insights.sbomify.com/CVE-2026-45623/"}