# CVE-2026-45623: PostCSS: Arbitrary file read and information disclosure via attacker-controlled sourceMappingURL in CSS comments

> Attackers can read arbitrary local files and cause denial of service by injecting malicious sourceMappingURL comments into CSS processed by PostCSS.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jul 2026
- **Updated:** 27 Jul 2026
- **Also known as:** CLSA-2026-1784856189, CLSA-2026-1784856448, CLSA-2026-1784943201, CLSA-2026-1785117457, CLSA-2026-1785117465, CLSA-2026-1785204444, CLSA-2026-1785204576, CLSA-2026-1785291205, CLSA-2026-1790190302, CLSA-2026-1790200920, CLSA-2026-1792164377, DEBIAN-CVE-2026-45623, ECHO-3dd3-3c70-3964, GHSA-6g55-p6wh-862q, MINI-6544-3ccf-3334, MINI-8j67-f2c6-q9xh, MINI-98r2-vhf5-44pp, MINI-ggwg-939q-9r2p, MINI-mg84-rwc9-42mj, MINI-rw43-5r5j-mrfr, MINI-v7f6-9845-6j55, MINI-xcgc-526c-5m6p, ROOT-APP-NPM-CVE-2026-45623, UBUNTU-CVE-2026-45623

## What is CVE-2026-45623?

CVE-2026-45623 is a high-severity path traversal vulnerability in postcss, published on 27 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PostCSS takes a CSS file and provides an API to analyze and modify its rules by transforming the rules into an Abstract Syntax Tree. In versions 8.5.11 and prior, the PreviousMap parses the /*# sourceMappingURL=PATH */ comment from any CSS string passed to process() and dereferences PATH against the local filesystem with no scheme, allowlist, or traversal check. An attacker who controls the CSS input can cause the host process to read any file readable by Node and leak the first ~10 bytes of its content through the resulting JSON.parse SyntaxError message. The bug also yields a precise file-existence oracle and a controllable-read primitive that may be combined with large-file targets for DoS. The behaviour is triggered with PostCSS's default options — no from, no map, no plugins required — and is therefore reachable from any pipeline that runs untrusted CSS through PostCSS (CMS themes, user-uploaded styles, browser-extension/userstyle processors, build pipelines for third-party packages, blog comment renderers, etc.). This issue has been fixed in version 8.5.12.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-45623?

2 open source packages ship an affected version, including postcss. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postcss` | npm | All versions | 8.5.12 |
| `postcss` | npm | All versions | 8.5.12 |

Products: Postcss Postcss.

## How do I fix CVE-2026-45623?

Upgrade postcss to 8.5.12 or later.

## Is CVE-2026-45623 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45623 exists.

## Other vulnerabilities in postcss

- [CVE-2026-69153](https://insights.sbomify.com/CVE-2026-69153/): PostCSS: incomplete fix of GHSA-6g55-p6wh-862q — attacker-controlled sourceMappingURL reads arbitrary .map files when `from` is unset (medium 6.3)
- [CVE-2023-44270](https://insights.sbomify.com/CVE-2023-44270/): PostCSS line return parsing error (medium 5.3)
- [CVE-2021-23382](https://insights.sbomify.com/CVE-2021-23382/): Regular Expression Denial of Service (ReDoS) (medium 5.3)
- [CVE-2021-23368](https://insights.sbomify.com/CVE-2021-23368/): Regular Expression Denial of Service (ReDoS) (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45623 and fix it if it is affected.

What it is: CVE-2026-45623 is a high-severity path traversal vulnerability in postcss, published on 27 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45623 exists.

Affected packages and fixed versions:
- postcss (npm): affected all versions; fixed in 8.5.12
- postcss (npm): affected all versions; fixed in 8.5.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45623/ (Markdown: https://insights.sbomify.com/CVE-2026-45623/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45623
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45623
- OSV: https://osv.dev/vulnerability/CVE-2026-45623

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45623/
Summaries are generated and may contain mistakes; the official description above is the record.
