# CVE-2026-45631: Dokploy: Pre-Auth Admin Takeover via Hardcoded Authentication Secret

> An unauthenticated attacker can exploit a hardcoded secret to forge admin tokens, take over the account, and execute commands on the host.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 May 2026
- **Updated:** 1 Jun 2026
- **Also known as:** GHSA-w3gm-rc4p-9rhj

## What is CVE-2026-45631?

CVE-2026-45631 is a critical vulnerability in dokploy, published on 29 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Dokploy is a free, self-hostable Platform as a Service (PaaS). From 0.27.0 to before 0.29.3, a hardcoded BETTER_AUTH_SECRET fallback ("better-auth-secret-123456789") lets an unauthenticated attacker forge email verification JWTs, trigger auto-sign-in as admin, and execute commands on the host via the built-in SSH terminal. This vulnerability is fixed in 0.29.3.

Weakness: CWE-798 (Use of Hard-coded Credentials)

## Which versions are affected by CVE-2026-45631?


## How do I fix CVE-2026-45631?

No fix has been published for CVE-2026-45631 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-45631 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45631 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45631 and fix it if it is affected.

What it is: CVE-2026-45631 is a critical vulnerability in dokploy, published on 29 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45631 exists.

Affected product: dokploy. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45631/ (Markdown: https://insights.sbomify.com/CVE-2026-45631/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45631
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45631
- OSV: https://osv.dev/vulnerability/CVE-2026-45631

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45631/
Summaries are generated and may contain mistakes; the official description above is the record.
