CVE-2026-45660 Statamic: Server-Side Request Forgery via Glide
Unauthenticated attackers can bypass URL validation in Statamic's Glide image proxy to make requests to internal network addresses, potentially accessing sensitive metadata.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-45660?
CVE-2026-45660 is a medium-severity server-side request forgery vulnerability in statamic cms, published on 29 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Statamic is a Laravel and Git powered content management system (CMS). Prior to 5.73.22 and 6.18.1, the Glide image proxy's URL validation could be bypassed using an IP representation that wasn't normalized before the public-IP check. An unauthenticated user could cause the server to make HTTP requests to internal addresses — including loopback, private network, and cloud metadata endpoints. This affects sites that pass user-supplied URLs to Glide. Sites running PHP 8.3 or newer are not affected. This vulnerability is fixed in 5.73.22 and 6.18.1.
Weakness: CWE-918
Which versions are affected by CVE-2026-45660?
4 open source packages ship an affected version, including statamic/cms.
| Package | Affected | Fixed in |
|---|---|---|
statamic/cms Packagist | All versions | 5.73.22 |
statamic/cms Packagist | All versions | 5.73.22 |
statamic/cms Packagist | From 6.0.0-alpha.1 | 6.18.1 |
statamic/cms Packagist | From 6.0.0-alpha.1 | 6.18.1 |
How do I fix CVE-2026-45660?
Upgrade statamic/cms to a fixed version for your release line: 5.73.22 or 6.18.1.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2026-45660 being exploited?
There is no known exploitation of CVE-2026-45660 in the wild and no public exploit code.
Sources
Also known as GHSA-pf9c-ch8r-2958.