# CVE-2026-45690: Nextcloud: Two-Factor Authentication Bypass via Pending Session Token Replay

> Attackers with valid passwords can bypass two-factor authentication by replaying temporary session tokens, gaining unauthorized access to Nextcloud accounts.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2026
- **Updated:** 2 Jun 2026
- **Also known as:** BIT-nextcloud-2026-45690, GHSA-jgcj-v42r-9922

## What is CVE-2026-45690?

CVE-2026-45690 is a medium-severity authentication bypass vulnerability in Nextcloud Nextcloud Server, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Nextcloud is an open source content collaboration platform. In Nextcloud Server from versions 32.0.0 to before 32.0.9, and 33.0.0 to before 33.0.3, an authentication bypass vulnerability allowed attackers with knowledge of a user's password to circumvent two-factor authentication (2FA) protections. When a user initiated login with valid credentials on a 2FA-enabled account, the system created a temporary session token before enforcing the second factor challenge. This token could be extracted and replayed via HTTP Basic Authentication to gain unauthorized access to authenticated endpoints. It is recommended that the Nextcloud Server is upgraded to 33.0.3 or 32.0.9. It is recommended that the Nextcloud Enterprise Server is upgraded to 33.0.3, 32.0.9, 31.0.14.5, 30.0.17.9 or 29.0.16.16

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-45690?

1 open source package ship an affected version, including nextcloud. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nextcloud` | Bitnami | From 32.0.0 | 32.0.9, 33.0.3 |

Products: Nextcloud Nextcloud Server.

## How do I fix CVE-2026-45690?

Upgrade nextcloud to a fixed version for your release line: 32.0.9 or 33.0.3.

## Is CVE-2026-45690 being exploited?

There is no known exploitation of CVE-2026-45690 in the wild and no public exploit code.

## Other vulnerabilities in Nextcloud Nextcloud Server

- [CVE-2021-32802](https://insights.sbomify.com/CVE-2021-32802/): Preview generation used third-party library not suited for user-generated content in Nextcloud server (critical 9.3)
- [CVE-2023-26482](https://insights.sbomify.com/CVE-2023-26482/): Scope of workflow operations is not validated in nextcloud server (critical 9.1)
- [CVE-2018-3775](https://insights.sbomify.com/CVE-2018-3775/): Auth bypass in Nextcloud Server (high 8.8)
- [CVE-2023-35172](https://insights.sbomify.com/CVE-2023-35172/): Nextcloud Server password reset endpoint is not brute force protected (high 8.7)
- [CVE-2023-32320](https://insights.sbomify.com/CVE-2023-32320/): Nextcloud Server's brute force protection allows someone to send more requests than intended (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45690 and fix it if it is affected.

What it is: CVE-2026-45690 is a medium-severity authentication bypass vulnerability in Nextcloud Nextcloud Server, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45690 in the wild and no public exploit code.

Affected packages and fixed versions:
- nextcloud (Bitnami): affected from 32.0.0; fixed in 32.0.9, 33.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45690/ (Markdown: https://insights.sbomify.com/CVE-2026-45690/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45690
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45690
- OSV: https://osv.dev/vulnerability/CVE-2026-45690

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45690/
Summaries are generated and may contain mistakes; the official description above is the record.
