# CVE-2026-45697: Formie: Pre-authenticated server-side template injection in Hidden fields

> Unauthenticated attackers can execute arbitrary code via Twig injection in Formie Hidden fields, compromising the Craft CMS site.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2026
- **Updated:** 1 Jun 2026
- **Also known as:** GHSA-x7m9-mwc2-g6w2

## What is CVE-2026-45697?

CVE-2026-45697 is a critical code injection vulnerability in verbb formie, published on 29 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Formie is a Craft CMS plugin for creating forms. Prior to 2.2.20 and 3.1.24, unauthenticated users could submit crafted values into Hidden fields (with Default value → Custom) that were evaluated as Twig during submission handling, which could lead to serious compromise of the Craft site (depending on template/sandbox behavior). This vulnerability is fixed in 2.2.20 and 3.1.24.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-693 (Protection Mechanism Failure), CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2026-45697?

4 open source packages ship an affected version, including verbb/formie.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `verbb/formie` | Packagist | All versions | 2.2.20 |
| `verbb/formie` | Packagist | All versions | 2.2.20 |
| `verbb/formie` | Packagist | From 3.0.0-beta.1 | 3.1.24 |
| `verbb/formie` | Packagist | From 3.0.0-beta.1 | 3.1.24 |

## How do I fix CVE-2026-45697?

Upgrade verbb/formie to a fixed version for your release line: 2.2.20 or 3.1.24.

## Is CVE-2026-45697 being exploited?

There is no known exploitation of CVE-2026-45697 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45697 and fix it if it is affected.

What it is: CVE-2026-45697 is a critical code injection vulnerability in verbb formie, published on 29 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45697 in the wild and no public exploit code.

Affected packages and fixed versions:
- verbb/formie (Packagist): affected all versions; fixed in 2.2.20
- verbb/formie (Packagist): affected all versions; fixed in 2.2.20
- verbb/formie (Packagist): affected from 3.0.0-beta.1; fixed in 3.1.24
- verbb/formie (Packagist): affected from 3.0.0-beta.1; fixed in 3.1.24

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45697/ (Markdown: https://insights.sbomify.com/CVE-2026-45697/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45697
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45697
- OSV: https://osv.dev/vulnerability/CVE-2026-45697

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45697/
Summaries are generated and may contain mistakes; the official description above is the record.
