# CVE-2026-45705: OpenSIPS: OOB Read in Multipart Body Boundary Parsing

> An out-of-bounds read in OpenSIPS allows attackers to cause denial of service or disclose memory contents via crafted SIP messages.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 4 Aug 2026
- **Updated:** 5 Aug 2026
- **Also known as:** GHSA-chxf-9368-fqcp, UBUNTU-CVE-2026-45705

## What is CVE-2026-45705?

CVE-2026-45705 is a medium-severity memory corruption vulnerability in opensips, published on 4 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. In versions prior to 3.6.6 and 4.0.0-rc1, the find_line_delimiter() function in the multipart body parser performs an out-of-bounds read via strncmp() when searching for MIME boundary delimiters. After finding a -- pattern near the end of the body, the function compares delimiter.len bytes (typically 20-70) starting from a position at or past the logical end of the body buffer, reading past the body boundary. The bug triggers when a SIP message has Content-Type: multipart/mixed with a boundary parameter and its body contains -- within two to three bytes of the body's end without being followed by the actual boundary delimiter. This issue has been fixed in versions 3.6.6 and 4.0.0-rc1.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-45705?


## How do I fix CVE-2026-45705?

No fix has been published for CVE-2026-45705 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-45705 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45705 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45705 and fix it if it is affected.

What it is: CVE-2026-45705 is a medium-severity memory corruption vulnerability in opensips, published on 4 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45705 exists.

Affected product: opensips. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45705/ (Markdown: https://insights.sbomify.com/CVE-2026-45705/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45705
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45705
- OSV: https://osv.dev/vulnerability/CVE-2026-45705

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45705/
Summaries are generated and may contain mistakes; the official description above is the record.
