# CVE-2026-45708: CubeCart: Authenticated RCE via Invoice Template → Order Print

> An admin can inject PHP code into invoice templates, leading to remote code execution when orders are printed by any user.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 May 2026
- **Updated:** 14 May 2026
- **Also known as:** GHSA-747j-4mmc-cj63

## What is CVE-2026-45708?

CVE-2026-45708 is a high-severity code injection vulnerability in cubecart v6, published on 13 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

CubeCart is an ecommerce software solution. Prior to 6.7.3, an admin with documents edit permission can save raw <?php … ?> into the Invoice Editor. The next time any admin clicks Print on any order, the rendered template is written to files/print.<md5>.php. files/.htaccess ships an explicit <Files print.*.php> allow from all </Files> carve-out, so the file is fetched and executed by any unauthenticated visitor. This vulnerability is fixed in 6.7.3.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-45708?


## How do I fix CVE-2026-45708?

No fix has been published for CVE-2026-45708 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-45708 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45708 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45708 and fix it if it is affected.

What it is: CVE-2026-45708 is a high-severity code injection vulnerability in cubecart v6, published on 13 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45708 exists.

Affected product: cubecart v6. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45708/ (Markdown: https://insights.sbomify.com/CVE-2026-45708/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45708
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45708
- OSV: https://osv.dev/vulnerability/CVE-2026-45708

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45708/
Summaries are generated and may contain mistakes; the official description above is the record.
