# CVE-2026-45711: Mailpit: Path traversal & arbitrary file write in mailpit dump --http via attacker-controlled message IDs

> A malicious server can exploit path traversal in Mailpit's dump command to write arbitrary files outside the intended directory, potentially leading to code execution.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Jul 2026
- **Updated:** 21 Jul 2026
- **Also known as:** GHSA-qx5x-85p8-vg4j, GO-2026-5599

## What is CVE-2026-45711?

CVE-2026-45711 is a medium-severity path traversal vulnerability in axllent mailpit, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Mailpit is an email testing tool and API for developers. Prior to version 1.30.0, the mailpit dump --http <base-url> <out-dir> sub-command downloads every message from a remote Mailpit instance and writes each one as <id>.eml inside the user-supplied output directory. The message ID field is taken verbatim from the JSON response of the remote server and concatenated into the output path with path.Join, which silently normalizes `..` segments. A malicious HTTP server impersonating Mailpit can therefore make mailpit dump write attacker-controlled bytes to any path the running user can write, fully outside the intended output directory. Version 1.30.0 contains a patch.

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-45711?

3 open source packages ship an affected version, including github.com/axllent/mailpit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/axllent/mailpit` | Go | All versions | 1.30.0 |
| `github.com/axllent/mailpit` | Go | All versions | 1.30.0 |
| `github.com/axllent/mailpit` | Go | All versions | 1.30.0 |

Products: Axllent Mailpit.

## How do I fix CVE-2026-45711?

Upgrade github.com/axllent/mailpit to 1.30.0 or later.

## Is CVE-2026-45711 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45711 exists.

## Other vulnerabilities in axllent mailpit

- [CVE-2026-45713](https://insights.sbomify.com/CVE-2026-45713/): Mailpit: Unauthenticated remote memory-exhaustion DoS via unlimited SMTP DATA and /api/v1/send body sizes (high 7.5)
- [CVE-2026-22689](https://insights.sbomify.com/CVE-2026-22689/): Mailpit is vulnerable to Cross-Site WebSocket Hijacking (CSWSH) allowing unauthenticated access to emails (medium 6.5)
- [CVE-2026-45712](https://insights.sbomify.com/CVE-2026-45712/): Mailpit: Concurrent map read & write in proxy CSS rewriter - remote unauth crash (fatal error: concurrent map read and map write) (medium 5.9)
- [CVE-2026-45709](https://insights.sbomify.com/CVE-2026-45709/): Mailpit has an incomplete fix for GHSA-6jxm: HTML check still permits SSRF to private/loopback/IMDS via missing IP-filter dialer (medium 5.8)
- [CVE-2026-27808](https://insights.sbomify.com/CVE-2026-27808/): Mailpit is Vulnerable to Server-Side Request Forgery (SSRF) via Link Check API (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45711 and fix it if it is affected.

What it is: CVE-2026-45711 is a medium-severity path traversal vulnerability in axllent mailpit, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45711 exists.

Affected packages and fixed versions:
- github.com/axllent/mailpit (Go): affected all versions; fixed in 1.30.0
- github.com/axllent/mailpit (Go): affected all versions; fixed in 1.30.0
- github.com/axllent/mailpit (Go): affected all versions; fixed in 1.30.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45711/ (Markdown: https://insights.sbomify.com/CVE-2026-45711/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45711
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45711
- OSV: https://osv.dev/vulnerability/CVE-2026-45711

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45711/
Summaries are generated and may contain mistakes; the official description above is the record.
