# CVE-2026-45712: Mailpit: Concurrent map read & write in proxy CSS rewriter - remote unauth crash (fatal error: concurrent map read and map write)

> Unauthenticated remote attackers can crash the Mailpit server via a race condition in the proxy CSS rewriter, causing a denial of service.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jul 2026
- **Updated:** 20 Jul 2026
- **Also known as:** GHSA-w4vj-r5pg-3722, GO-2026-5689

## What is CVE-2026-45712?

CVE-2026-45712 is a medium-severity vulnerability in axllent mailpit, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mailpit is an email testing tool and API for developers. Prior to version 1.30.0, the screenshot/print proxy (/proxy?data=…) maintains a package-level assets map[string]MessageAssets cache, but reads the map without holding assetsMutex while a long-running cleanup goroutine and (re-entrant) CSS-rewriting code path concurrently write to it under the lock. When the unsynchronized read coincides with a synchronized write, Go's runtime raises fatal error: concurrent map read and map write — a runtime.throw that is not recoverable by http.Server's handler-panic recover. The whole Mailpit process exits, taking the SMTP, POP3 and HTTP listeners down with it. Version 1.30.0 contains a patch.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2026-45712?

3 open source packages ship an affected version, including github.com/axllent/mailpit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/axllent/mailpit` | Go | All versions | 1.30.0 |
| `github.com/axllent/mailpit` | Go | All versions | 1.30.0 |
| `github.com/axllent/mailpit` | Go | All versions | 1.30.0 |

Products: Axllent Mailpit.

## How do I fix CVE-2026-45712?

Upgrade github.com/axllent/mailpit to 1.30.0 or later.

## Is CVE-2026-45712 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45712 exists.

## Other vulnerabilities in axllent mailpit

- [CVE-2026-45713](https://insights.sbomify.com/CVE-2026-45713/): Mailpit: Unauthenticated remote memory-exhaustion DoS via unlimited SMTP DATA and /api/v1/send body sizes (high 7.5)
- [CVE-2026-22689](https://insights.sbomify.com/CVE-2026-22689/): Mailpit is vulnerable to Cross-Site WebSocket Hijacking (CSWSH) allowing unauthenticated access to emails (medium 6.5)
- [CVE-2026-45711](https://insights.sbomify.com/CVE-2026-45711/): Mailpit: Path traversal & arbitrary file write in mailpit dump --http via attacker-controlled message IDs (medium 5.9)
- [CVE-2026-45709](https://insights.sbomify.com/CVE-2026-45709/): Mailpit has an incomplete fix for GHSA-6jxm: HTML check still permits SSRF to private/loopback/IMDS via missing IP-filter dialer (medium 5.8)
- [CVE-2026-27808](https://insights.sbomify.com/CVE-2026-27808/): Mailpit is Vulnerable to Server-Side Request Forgery (SSRF) via Link Check API (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45712 and fix it if it is affected.

What it is: CVE-2026-45712 is a medium-severity vulnerability in axllent mailpit, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45712 exists.

Affected packages and fixed versions:
- github.com/axllent/mailpit (Go): affected all versions; fixed in 1.30.0
- github.com/axllent/mailpit (Go): affected all versions; fixed in 1.30.0
- github.com/axllent/mailpit (Go): affected all versions; fixed in 1.30.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45712/ (Markdown: https://insights.sbomify.com/CVE-2026-45712/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45712
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45712
- OSV: https://osv.dev/vulnerability/CVE-2026-45712

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45712/
Summaries are generated and may contain mistakes; the official description above is the record.
