# CVE-2026-45713: Mailpit: Unauthenticated remote memory-exhaustion DoS via unlimited SMTP DATA and /api/v1/send body sizes

> Unauthenticated attackers can cause denial of service in Mailpit by sending unlimited SMTP or HTTP payloads, exhausting system memory.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jul 2026
- **Updated:** 20 Jul 2026
- **Also known as:** GHSA-fpxj-m5q8-fphw, GO-2026-5376

## What is CVE-2026-45713?

CVE-2026-45713 is a high-severity denial of service vulnerability in axllent mailpit, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mailpit is an email testing tool and API for developers. Prior to version 1.30.0, the Mailpit SMTP server has a Server.MaxSize int field that controls the maximum allowed DATA payload size, but the field is never assigned anywhere outside test code, leaving it at Go's zero value (0 ⇒ "no limit"). The same applies to the HTTP /api/v1/send endpoint, whose request body is decoded with json.NewDecoder(r.Body) and no http.MaxBytesReader. Because Mailpit's default listeners bind [::]:1025 (SMTP) and [::]:8025 (HTTP), with no authentication required on either, a single network-reachable attacker can push an arbitrarily large message into Mailpit and watch RAM consumption spike with a ~7-10× amplification factor (raw frame → enmime envelope tree → search-text index → zstd-encoded write to SQLite). Repeating the attack — or running it concurrently from multiple connections — drives the process to OOM-kill. Version 1.30.0 contains a patch.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-45713?

3 open source packages ship an affected version, including github.com/axllent/mailpit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/axllent/mailpit` | Go | All versions | 1.30.0 |
| `github.com/axllent/mailpit` | Go | All versions | 1.30.0 |
| `github.com/axllent/mailpit` | Go | All versions | 1.30.0 |

Products: Axllent Mailpit.

## How do I fix CVE-2026-45713?

Upgrade github.com/axllent/mailpit to 1.30.0 or later.

## Is CVE-2026-45713 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45713 exists.

## Other vulnerabilities in axllent mailpit

- [CVE-2026-22689](https://insights.sbomify.com/CVE-2026-22689/): Mailpit is vulnerable to Cross-Site WebSocket Hijacking (CSWSH) allowing unauthenticated access to emails (medium 6.5)
- [CVE-2026-45711](https://insights.sbomify.com/CVE-2026-45711/): Mailpit: Path traversal & arbitrary file write in mailpit dump --http via attacker-controlled message IDs (medium 5.9)
- [CVE-2026-45712](https://insights.sbomify.com/CVE-2026-45712/): Mailpit: Concurrent map read & write in proxy CSS rewriter - remote unauth crash (fatal error: concurrent map read and map write) (medium 5.9)
- [CVE-2026-45709](https://insights.sbomify.com/CVE-2026-45709/): Mailpit has an incomplete fix for GHSA-6jxm: HTML check still permits SSRF to private/loopback/IMDS via missing IP-filter dialer (medium 5.8)
- [CVE-2026-27808](https://insights.sbomify.com/CVE-2026-27808/): Mailpit is Vulnerable to Server-Side Request Forgery (SSRF) via Link Check API (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45713 and fix it if it is affected.

What it is: CVE-2026-45713 is a high-severity denial of service vulnerability in axllent mailpit, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45713 exists.

Affected packages and fixed versions:
- github.com/axllent/mailpit (Go): affected all versions; fixed in 1.30.0
- github.com/axllent/mailpit (Go): affected all versions; fixed in 1.30.0
- github.com/axllent/mailpit (Go): affected all versions; fixed in 1.30.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45713/ (Markdown: https://insights.sbomify.com/CVE-2026-45713/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45713
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45713
- OSV: https://osv.dev/vulnerability/CVE-2026-45713

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45713/
Summaries are generated and may contain mistakes; the official description above is the record.
