# CVE-2026-45716: Budibase: Builder-to-Admin Privilege Escalation via onboardUsers Endpoint Without SMTP Configuration

> A builder user can escalate to admin by creating accounts via the onboard endpoint when SMTP is unconfigured, allowing full platform takeover.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2026
- **Updated:** 27 May 2026
- **Also known as:** GHSA-c54j-xp92-wh28

## What is CVE-2026-45716?

CVE-2026-45716 is a high-severity vulnerability in budibase, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Budibase is an open-source low-code platform. Prior to 3.38.1, the POST /api/global/users/onboard endpoint is protected by workspaceBuilderOrAdmin middleware, allowing any user with builder permissions to access it. When SMTP email is not configured (the default for self-hosted Budibase instances), this endpoint bypasses the admin-restricted invite flow and directly creates users via bulkCreate, accepting arbitrary admin and builder role assignments from the request body. A builder-level user can create a new global admin account and receive the generated password in the response, achieving full privilege escalation. This vulnerability is fixed in 3.38.1.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-45716?

2 open source packages ship an affected version, including @budibase/worker.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@budibase/worker` | npm | All versions | 3.38.1 |
| `@budibase/worker` | npm | All versions | 3.38.1 |

## How do I fix CVE-2026-45716?

Upgrade @budibase/worker to 3.38.1 or later.

## Is CVE-2026-45716 being exploited?

There is no known exploitation of CVE-2026-45716 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45716 and fix it if it is affected.

What it is: CVE-2026-45716 is a high-severity vulnerability in budibase, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45716 in the wild and no public exploit code.

Affected packages and fixed versions:
- @budibase/worker (npm): affected all versions; fixed in 3.38.1
- @budibase/worker (npm): affected all versions; fixed in 3.38.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45716/ (Markdown: https://insights.sbomify.com/CVE-2026-45716/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45716
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45716
- OSV: https://osv.dev/vulnerability/CVE-2026-45716

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45716/
Summaries are generated and may contain mistakes; the official description above is the record.
