# CVE-2026-45717: Budibase: `PUT /api/datasources/:datasourceId` is protected only by `TABLE/READ` permission instead of builder access, allowing any authenticated app user to overwrite datasource connection parameters including host, port, and URL

> Authenticated users can overwrite datasource configurations due to missing builder checks, enabling internal service probing and credential theft.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2026
- **Updated:** 27 May 2026
- **Also known as:** GHSA-44m2-crh7-f4q2

## What is CVE-2026-45717?

CVE-2026-45717 is a high-severity missing authorization vulnerability in budibase, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Budibase is an open-source low-code platform. Prior to 3.38.1, Budibase exposes a REST API for datasource management. The route PUT /api/datasources/:datasourceId is registered in the authorizedRoutes group with TABLE/READ permission. This is the same authorization level as the read endpoint (GET /api/datasources/:datasourceId). Every authenticated Budibase app user with the BASIC built-in role or higher carries TABLE/WRITE (and therefore TABLE/READ) permissions, and the datasource update controller performs no additional builder check. As a result, any authenticated non-builder app user can submit a PUT request to rewrite a datasource's config object — including the connection host, port, database credentials, or the base url of a REST datasource. Because no network-level SSRF protection is applied to SQL driver connections, redirecting a PostgreSQL/MySQL/MongoDB datasource to an internal IP address succeeds and the attacker can probe or interact with internal services on arbitrary ports. This vulnerability is fixed in 3.38.1.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-45717?

2 open source packages ship an affected version, including @budibase/server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@budibase/server` | npm | All versions | 3.38.1 |
| `@budibase/server` | npm | All versions | 3.38.1 |

## How do I fix CVE-2026-45717?

Upgrade @budibase/server to 3.38.1 or later.

## Is CVE-2026-45717 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45717 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45717 and fix it if it is affected.

What it is: CVE-2026-45717 is a high-severity missing authorization vulnerability in budibase, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45717 exists.

Affected packages and fixed versions:
- @budibase/server (npm): affected all versions; fixed in 3.38.1
- @budibase/server (npm): affected all versions; fixed in 3.38.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45717/ (Markdown: https://insights.sbomify.com/CVE-2026-45717/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45717
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45717
- OSV: https://osv.dev/vulnerability/CVE-2026-45717

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45717/
Summaries are generated and may contain mistakes; the official description above is the record.
