{"answers":{"affected":"2 open source packages ship an affected version, including budibase.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45718 exists.","fix":"Upgrade budibase to 3.38.1 or later.","what":"CVE-2026-45718 is a medium-severity missing authorization vulnerability in budibase, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-45718 and fix it if it is affected.\n\nWhat it is: CVE-2026-45718 is a medium-severity missing authorization vulnerability in budibase, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45718 exists.\n\nAffected packages and fixed versions:\n- budibase (npm): affected all versions; fixed in 3.38.1\n- budibase (npm): affected all versions; fixed in 3.38.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-45718/ (Markdown: https://insights.sbomify.com/CVE-2026-45718/index.md)","id":"CVE-2026-45718","markdown":"https://insights.sbomify.com/CVE-2026-45718/index.md","name":"CVE-2026-45718","record":{"aliases":["GHSA-3263-v5v9-xq8q"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Budibase low-code platform","requires_auth":"low_privilege","summary":"Attackers can execute row actions on data excluded by view filters, bypassing security boundaries in Budibase.\n","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"Budibase is an open-source low-code platform. Prior to 3.38.1, the row action trigger endpoint (POST /api/tables/:sourceId/actions/:actionId/trigger) fails to validate that the user-supplied rowId is within the scope of the view's row filters. A user with access to a filtered view can trigger row actions on any row in the underlying table, including rows explicitly excluded by the view's security filters. This vulnerability is fixed in 3.38.1.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Budibase: Row Action Trigger Bypasses View Row Filter Security Boundary Allowing Action on Out-of-Scope Rows","id":"CVE-2026-45718","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Budibase: CouchDB Reduce Injection via Unsanitized Calculation Parameter in V1 Views API","id":"CVE-2026-45719"},"packages":[{"ecosystem":"npm","fixed":["3.38.1"],"introduced":["0"],"last_affected":[],"package":"budibase","purl":null,"source":"GHSA-3263-v5v9-xq8q"},{"ecosystem":"npm","fixed":["3.38.1"],"introduced":["0"],"last_affected":[],"package":"budibase","purl":"pkg:npm/budibase","source":"GHSA-3263-v5v9-xq8q"}],"prev":{"headline":"Budibase: `PUT /api/datasources/:datasourceId` is protected only by `TABLE/READ` permission instead of builder access, allowing any authenticated app user to overwrite datasource connection parameters including host, port, and URL","id":"CVE-2026-45717"},"products":["budibase"],"published":"2026-05-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-28","vendors":["Budibase"]},"summary":"Attackers can execute row actions on data excluded by view filters, bypassing security boundaries in Budibase.\n","url":"https://insights.sbomify.com/CVE-2026-45718/"}