# CVE-2026-45718: Budibase: Row Action Trigger Bypasses View Row Filter Security Boundary Allowing Action on Out-of-Scope Rows

> Attackers can execute row actions on data excluded by view filters, bypassing security boundaries in Budibase.


- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2026
- **Updated:** 28 May 2026
- **Also known as:** GHSA-3263-v5v9-xq8q

## What is CVE-2026-45718?

CVE-2026-45718 is a medium-severity missing authorization vulnerability in budibase, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Budibase is an open-source low-code platform. Prior to 3.38.1, the row action trigger endpoint (POST /api/tables/:sourceId/actions/:actionId/trigger) fails to validate that the user-supplied rowId is within the scope of the view's row filters. A user with access to a filtered view can trigger row actions on any row in the underlying table, including rows explicitly excluded by the view's security filters. This vulnerability is fixed in 3.38.1.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-45718?

2 open source packages ship an affected version, including budibase.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `budibase` | npm | All versions | 3.38.1 |
| `budibase` | npm | All versions | 3.38.1 |

## How do I fix CVE-2026-45718?

Upgrade budibase to 3.38.1 or later.

## Is CVE-2026-45718 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45718 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45718 and fix it if it is affected.

What it is: CVE-2026-45718 is a medium-severity missing authorization vulnerability in budibase, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45718 exists.

Affected packages and fixed versions:
- budibase (npm): affected all versions; fixed in 3.38.1
- budibase (npm): affected all versions; fixed in 3.38.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45718/ (Markdown: https://insights.sbomify.com/CVE-2026-45718/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45718
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45718
- OSV: https://osv.dev/vulnerability/CVE-2026-45718

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45718/
Summaries are generated and may contain mistakes; the official description above is the record.
