# CVE-2026-45719: Budibase: CouchDB Reduce Injection via Unsanitized Calculation Parameter in V1 Views API

> A user with Builder permissions can inject arbitrary JavaScript into CouchDB views via the V1 Views API, leading to remote code execution.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2026
- **Updated:** 27 May 2026
- **Also known as:** GHSA-363w-hvwh-w7m6

## What is CVE-2026-45719?

CVE-2026-45719 is a medium-severity code injection vulnerability in budibase, published on 27 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Budibase is an open-source low-code platform. Prior to 3.38.1, the V1 Views API (POST /api/views) accepts a calculation parameter from the request body that is interpolated directly into a CouchDB reduce function definition without validation. Although an internal SCHEMA_MAP object defines the valid calculation types (sum, count, stats), no actual validation is performed against this map before the value is used in string interpolation. A user with Builder permissions can inject arbitrary JavaScript code that will be executed within the CouchDB JavaScript engine when the view is queried. This vulnerability is fixed in 3.38.1.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-45719?

2 open source packages ship an affected version, including @budibase/server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@budibase/server` | npm | All versions | 3.38.1 |
| `@budibase/server` | npm | All versions | 3.38.1 |

## How do I fix CVE-2026-45719?

Upgrade @budibase/server to 3.38.1 or later.

## Is CVE-2026-45719 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45719 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45719 and fix it if it is affected.

What it is: CVE-2026-45719 is a medium-severity code injection vulnerability in budibase, published on 27 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45719 exists.

Affected packages and fixed versions:
- @budibase/server (npm): affected all versions; fixed in 3.38.1
- @budibase/server (npm): affected all versions; fixed in 3.38.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45719/ (Markdown: https://insights.sbomify.com/CVE-2026-45719/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45719
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45719
- OSV: https://osv.dev/vulnerability/CVE-2026-45719

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45719/
Summaries are generated and may contain mistakes; the official description above is the record.
