CVE-2026-45754 Symfony: Mailjet Mailer Webhook Parser Never Verifies the Configured Secret — Unauthenticated Webhook Event Injection
Attackers can inject forged webhook events into Symfony Mailjet and LOX24 bridges because the configured secrets are not verified, allowing unauthenticated data manipulation.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-45754?
CVE-2026-45754 is a medium-severity missing authorization vulnerability in Sensiolabs Symfony, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 6.4.40, 7.4.12, and 8.0.12, the Mailjet mailer bridge and LOX24 notifier bridge webhook parsers received configured webhook secrets but did not verify them, allowing unauthenticated POST requests to inject forged Mailjet and LOX24 event payloads. This issue is fixed in versions 6.4.40, 7.4.12, and 8.0.12.
Which versions are affected by CVE-2026-45754?
16 open source packages ship an affected version, including symfony/mailjet-mailer, symfony/lox24-notifier and symfony/symfony. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
symfony/mailjet-mailer Packagist | From 6.4.0 | 6.4.40 |
symfony/mailjet-mailer Packagist | From 6.4.0 | 6.4.40 |
symfony/mailjet-mailer Packagist | From 7.0.0 | 7.4.12 |
symfony/mailjet-mailer Packagist | From 7.0.0 | 7.4.12 |
symfony/mailjet-mailer Packagist | From 8.0.0 | 8.0.12 |
symfony/mailjet-mailer Packagist | From 8.0.0 | 8.0.12 |
10 more packages
symfony/lox24-notifier Packagist | From 7.1.0 | 7.4.12 |
symfony/lox24-notifier Packagist | From 7.1.0 | 7.4.12 |
symfony/lox24-notifier Packagist | From 8.0.0 | 8.0.12 |
symfony/lox24-notifier Packagist | From 8.0.0 | 8.0.12 |
symfony/symfony Packagist | From 6.4.0 | 6.4.40 |
symfony/symfony Packagist | From 6.4.0 | 6.4.40 |
symfony/symfony Packagist | From 7.0.0 | 7.4.12 |
symfony/symfony Packagist | From 7.0.0 | 7.4.12 |
symfony/symfony Packagist | From 8.0.0 | 8.0.12 |
symfony/symfony Packagist | From 8.0.0 | 8.0.12 |
Products include Sensiolabs Symfony.
How do I fix CVE-2026-45754?
Upgrade symfony/mailjet-mailer to a fixed version for your release line: 6.4.40, 7.4.12 or 8.0.12.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-45754 being exploited?
There is no known exploitation of CVE-2026-45754 in the wild and no public exploit code.
Other vulnerabilities in Sensiolabs Symfony
Sources
Also known as DEBIAN-CVE-2026-45754, GHSA-64hg-93w9-fc35, UBUNTU-CVE-2026-45754.