# CVE-2026-45755: Symfony's Mailtrap Mailer Webhook Parser Never Verifies the X-Mt-Signature HMAC — Unauthenticated Webhook Event Injection

> Attackers can inject forged email delivery events by bypassing HMAC signature verification in the Symfony Mailtrap Mailer webhook parser.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2026
- **Updated:** 14 Jul 2026
- **Also known as:** DEBIAN-CVE-2026-45755, GHSA-59f3-vp2f-mp9w, UBUNTU-CVE-2026-45755

## What is CVE-2026-45755?

CVE-2026-45755 is a medium-severity missing authorization vulnerability in Sensiolabs Symfony, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 7.4.12 and 8.0.12, MailtrapRequestParser::doParse() received the configured webhook secret but ignored the X-Mt-Signature HMAC header, allowing unauthenticated POST requests to inject forged Mailtrap delivery, bounce, open, click, or spam events. This issue is fixed in versions 7.4.12 and 8.0.12.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature), CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-45755?

8 open source packages ship an affected version, including symfony/mailtrap-mailer and symfony/symfony. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/mailtrap-mailer` | Packagist | From 7.2.0 | 7.4.12 |
| `symfony/mailtrap-mailer` | Packagist | From 7.2.0 | 7.4.12 |
| `symfony/mailtrap-mailer` | Packagist | From 8.0.0 | 8.0.12 |
| `symfony/mailtrap-mailer` | Packagist | From 8.0.0 | 8.0.12 |
| `symfony/symfony` | Packagist | From 7.2.0 | 7.4.12 |
| `symfony/symfony` | Packagist | From 7.2.0 | 7.4.12 |
| `symfony/symfony` | Packagist | From 8.0.0 | 8.0.12 |
| `symfony/symfony` | Packagist | From 8.0.0 | 8.0.12 |

Products: Sensiolabs Symfony.

## How do I fix CVE-2026-45755?

Upgrade symfony/mailtrap-mailer to a fixed version for your release line: 7.4.12 or 8.0.12.

## Is CVE-2026-45755 being exploited?

There is no known exploitation of CVE-2026-45755 in the wild and no public exploit code.

## Other vulnerabilities in Sensiolabs Symfony

- [CVE-2019-11325](https://insights.sbomify.com/CVE-2019-11325/): Improper Input Validation in Symfony (critical 9.8)
- [CVE-2017-11365](https://insights.sbomify.com/CVE-2017-11365/): Symfony Incorrect Access Control (critical 9.8)
- [CVE-2019-10913](https://insights.sbomify.com/CVE-2019-10913/): Invalid HTTP method overrides allow possible XSS or other attacks in Symfony (critical 9.8)
- [CVE-2018-11407](https://insights.sbomify.com/CVE-2018-11407/): Symfony Authentication Bypass (critical 9.8)
- [CVE-2016-2403](https://insights.sbomify.com/CVE-2016-2403/): Symfony Authentication Bypass (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45755 and fix it if it is affected.

What it is: CVE-2026-45755 is a medium-severity missing authorization vulnerability in Sensiolabs Symfony, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45755 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/mailtrap-mailer (Packagist): affected from 7.2.0; fixed in 7.4.12
- symfony/mailtrap-mailer (Packagist): affected from 7.2.0; fixed in 7.4.12
- symfony/mailtrap-mailer (Packagist): affected from 8.0.0; fixed in 8.0.12
- symfony/mailtrap-mailer (Packagist): affected from 8.0.0; fixed in 8.0.12
- symfony/symfony (Packagist): affected from 7.2.0; fixed in 7.4.12
- symfony/symfony (Packagist): affected from 7.2.0; fixed in 7.4.12
- symfony/symfony (Packagist): affected from 8.0.0; fixed in 8.0.12
- symfony/symfony (Packagist): affected from 8.0.0; fixed in 8.0.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45755/ (Markdown: https://insights.sbomify.com/CVE-2026-45755/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45755
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45755
- OSV: https://osv.dev/vulnerability/CVE-2026-45755

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45755/
Summaries are generated and may contain mistakes; the official description above is the record.
