CVE-2026-45758 Malicious code in guardrails-ai 0.10.1 (supply chain compromise)

Critical 9.6 Published Updated

Attackers injected malicious code into a PyPI package, allowing execution and credential theft on systems installing the compromised version.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2026-45758?

CVE-2026-45758 is a critical vulnerability in guardrails-ai guardrails, published on 5 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Guardrails AI is a Python framework that helps build AI applications. On May 11, 2026 at approximately 6:00 PM Pacific, an attacker published a malicious version of `guardrails-ai` (0.10.1) to PyPI. Aany user who installed `guardrails-ai==0.10.1` from PyPI on May 11, 2026 may be affected. Security researchers identified the malicious package within approximately 2 hours of publication, and PyPI quarantined the repository. Based on our telemetry, Guardrails AI maintainers have observed no requests to Guardrails AI infrastructure originating from the malicious 0.10.1 version, and a review of system and access logs has produced no evidence of user data exfiltration through their systems. Users should upgrade to version 0.10.2 or downgrade to version 0.10.0, both of which are unaffected. Those who installed version 0.10.1 should rotate any credentials accessible from their machine (GitHub PATs, cloud provider keys, package registry tokens, API keys) and audit their GitHub account for unauthorized workflows or repositories.

Weakness: CWE-506

Which versions are affected by CVE-2026-45758?

3 open source packages ship an affected version, including guardrails-ai. It affects 1 product.

PackageAffectedFixed in
guardrails-ai PyPIAll versionsNone
guardrails-ai PyPIAll versionsNone
guardrails-ai PyPIAll versions to 0.10.1None

Products include Guardrailsai Guardrails Ai.

How do I fix CVE-2026-45758?

No fix has been published for CVE-2026-45758 yet. Limit exposure of the affected software until one is available.

Is CVE-2026-45758 being exploited?

There is no known exploitation of CVE-2026-45758 in the wild and no public exploit code.

Sources

Also known as GHSA-xmpw-2vmm-p4p6, PYSEC-2026-206.

Is CVE-2026-45758 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free