{"answers":{"affected":"3 open source packages ship an affected version, including guardrails-ai. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-45758 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-45758 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-45758 is a critical vulnerability in guardrails-ai guardrails, published on 5 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-45758 and fix it if it is affected.\n\nWhat it is: CVE-2026-45758 is a critical vulnerability in guardrails-ai guardrails, published on 5 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-45758 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- guardrails-ai (PyPI): affected all versions; no fix listed\n- guardrails-ai (PyPI): affected all versions; no fix listed\n- guardrails-ai (PyPI): affected all versions up to 0.10.1; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-45758/ (Markdown: https://insights.sbomify.com/CVE-2026-45758/index.md)","id":"CVE-2026-45758","markdown":"https://insights.sbomify.com/CVE-2026-45758/index.md","name":"CVE-2026-45758","record":{"aliases":["GHSA-xmpw-2vmm-p4p6","PYSEC-2026-206"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Python AI framework","requires_auth":"none","summary":"Attackers injected malicious code into a PyPI package, allowing execution and credential theft on systems installing the compromised version.","user_interaction":"required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"guardrails_ai","vendor":"guardrailsai"}],"cvss":{"score":9.6,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-506","name":"Embedded Malicious Code"}],"description":"Guardrails AI is a Python framework that helps build AI applications. On May 11, 2026 at approximately 6:00 PM Pacific, an attacker published a malicious version of `guardrails-ai` (0.10.1) to PyPI. Aany user who installed `guardrails-ai==0.10.1` from PyPI on May 11, 2026 may be affected. Security researchers identified the malicious package within approximately 2 hours of publication, and PyPI quarantined the repository. Based on our telemetry, Guardrails AI maintainers have observed no requests to Guardrails AI infrastructure originating from the malicious 0.10.1 version, and a review of system and access logs has produced no evidence of user data exfiltration through their systems. Users should upgrade to version 0.10.2 or downgrade to version 0.10.0, both of which are unaffected. Those who installed version 0.10.1 should rotate any credentials accessible from their machine (GitHub PATs, cloud provider keys, package registry tokens, API keys) and audit their GitHub account for unauthorized workflows or repositories.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Malicious code in guardrails-ai 0.10.1 (supply chain compromise)","id":"CVE-2026-45758","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"supply_chain","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"Suricata http1: quadratic Content-Disposition processing can lead to denial of service","id":"CVE-2026-45759"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":[],"last_affected":[],"package":"guardrails-ai","purl":null,"source":"GHSA-xmpw-2vmm-p4p6"},{"ecosystem":"PyPI","fixed":[],"introduced":[],"last_affected":[],"package":"guardrails-ai","purl":"pkg:pypi/guardrails-ai","source":"GHSA-xmpw-2vmm-p4p6"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["0.10.1"],"package":"guardrails-ai","purl":"pkg:pypi/guardrails-ai","source":"PYSEC-2026-206"}],"prev":{"headline":"Rocket.Chat: users.deactivateIdle` deactivates accounts without revoking existing login tokens","id":"CVE-2026-45757"},"products":["guardrails"],"published":"2026-06-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-06-08","vendors":["guardrails-ai"]},"summary":"Attackers injected malicious code into a PyPI package, allowing execution and credential theft on systems installing the compromised version.","url":"https://insights.sbomify.com/CVE-2026-45758/"}