CVE-2026-45760 Apache Camel K: Camel K Cross-Namespace Build Deputy Attack
Authorized users can create Build resources in arbitrary namespaces, including the operator namespace, leading to privilege escalation and potential code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-45760?
CVE-2026-45760 is a high-severity missing authorization vulnerability in Apache Camel K, published on 21 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
(Externally Controlled Reference to a Resource in Another Sphere), (Authorization Bypass Through User-Controlled Key) vulnerability in Apache Camel K. Authorized users in a Kubernetes namespace can create a Build resource, controlling the Pod generation in a namespace of their choice, including the operator namespace.
This issue affects Apache Camel K: from 2.0.0 before 2.8.1, from 2.9.0 before 2.9.2, from 2.10.0 before 2.10.1.
Users are recommended to upgrade to version 2.10.1 (or 2.8.1 or 2.9.2), which fixes the issue.
Which versions are affected by CVE-2026-45760?
8 open source packages ship an affected version, including github.com/apache/camel-k/v2 and github.com/apache/camel-k.
| Package | Affected | Fixed in |
|---|---|---|
github.com/apache/camel-k/v2 Go | All versions | 2.8.1, 2.9.2, 2.10.1 |
github.com/apache/camel-k/v2 Go | All versions | 2.8.1 |
github.com/apache/camel-k/v2 Go | All versions | 2.8.1 |
github.com/apache/camel-k/v2 Go | From 2.10.0 | 2.10.1 |
github.com/apache/camel-k/v2 Go | From 2.10.0 | 2.10.1 |
github.com/apache/camel-k/v2 Go | From 2.9.0 | 2.9.2 |
2 more packages
github.com/apache/camel-k/v2 Go | From 2.9.0 | 2.9.2 |
github.com/apache/camel-k Go | All versions | None |
How do I fix CVE-2026-45760?
Upgrade github.com/apache/camel-k/v2 to a fixed version for your release line: 2.8.1, 2.9.2 or 2.10.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-45760 being exploited?
There is no known exploitation of CVE-2026-45760 in the wild and no public exploit code.
Sources
Also known as GHSA-q8ch-jx67-q52x, GO-2026-5573.