# CVE-2026-45760: Apache Camel K: Camel K Cross-Namespace Build Deputy Attack

> Authorized users can create Build resources in arbitrary namespaces, including the operator namespace, leading to privilege escalation and potential code execution.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 May 2026
- **Updated:** 23 May 2026
- **Also known as:** GHSA-q8ch-jx67-q52x, GO-2026-5573

## What is CVE-2026-45760?

CVE-2026-45760 is a high-severity missing authorization vulnerability in Apache Camel K, published on 21 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

(Externally Controlled Reference to a Resource in Another Sphere), (Authorization Bypass Through User-Controlled Key) vulnerability in Apache Camel K. Authorized users in a Kubernetes namespace can create a Build resource, controlling the Pod generation in a namespace of their choice, including the operator namespace.

This issue affects Apache Camel K: from 2.0.0 before 2.8.1, from 2.9.0 before 2.9.2, from 2.10.0 before 2.10.1.

Users are recommended to upgrade to version 2.10.1 (or 2.8.1 or 2.9.2), which fixes the issue.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-610 (Externally Controlled Reference to a Resource in Another Sphere)

## Which versions are affected by CVE-2026-45760?

8 open source packages ship an affected version, including github.com/apache/camel-k/v2 and github.com/apache/camel-k.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/apache/camel-k/v2` | Go | All versions | 2.8.1, 2.9.2, 2.10.1 |
| `github.com/apache/camel-k/v2` | Go | All versions | 2.8.1 |
| `github.com/apache/camel-k/v2` | Go | All versions | 2.8.1 |
| `github.com/apache/camel-k/v2` | Go | From 2.10.0 | 2.10.1 |
| `github.com/apache/camel-k/v2` | Go | From 2.10.0 | 2.10.1 |
| `github.com/apache/camel-k/v2` | Go | From 2.9.0 | 2.9.2 |
| `github.com/apache/camel-k/v2` | Go | From 2.9.0 | 2.9.2 |
| `github.com/apache/camel-k` | Go | All versions | None |

## How do I fix CVE-2026-45760?

Upgrade github.com/apache/camel-k/v2 to a fixed version for your release line: 2.8.1, 2.9.2 or 2.10.1.

## Is CVE-2026-45760 being exploited?

There is no known exploitation of CVE-2026-45760 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45760 and fix it if it is affected.

What it is: CVE-2026-45760 is a high-severity missing authorization vulnerability in Apache Camel K, published on 21 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45760 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/apache/camel-k/v2 (Go): affected all versions; fixed in 2.8.1, 2.9.2, 2.10.1
- github.com/apache/camel-k/v2 (Go): affected all versions; fixed in 2.8.1
- github.com/apache/camel-k/v2 (Go): affected all versions; fixed in 2.8.1
- github.com/apache/camel-k/v2 (Go): affected from 2.10.0; fixed in 2.10.1
- github.com/apache/camel-k/v2 (Go): affected from 2.10.0; fixed in 2.10.1
- github.com/apache/camel-k/v2 (Go): affected from 2.9.0; fixed in 2.9.2
- github.com/apache/camel-k/v2 (Go): affected from 2.9.0; fixed in 2.9.2
- github.com/apache/camel-k (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45760/ (Markdown: https://insights.sbomify.com/CVE-2026-45760/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45760
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45760
- OSV: https://osv.dev/vulnerability/CVE-2026-45760

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45760/
Summaries are generated and may contain mistakes; the official description above is the record.
