{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-45782 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-45782 is a high-severity use after free vulnerability in cloud-hypervisor, published on 9 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-45782 and fix it if it is affected.\n\nWhat it is: CVE-2026-45782 is a high-severity use after free vulnerability in cloud-hypervisor, published on 9 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-45782 in the wild and no public exploit code.\n\nAffected product: cloud-hypervisor. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-45782/ (Markdown: https://insights.sbomify.com/CVE-2026-45782/index.md)","id":"CVE-2026-45782","markdown":"https://insights.sbomify.com/CVE-2026-45782/index.md","name":"CVE-2026-45782","record":{"aliases":["GHSA-f47p-p25q-83rh","openSUSE-SU-2026:10907-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Cloud Hypervisor VMM","requires_auth":"none","summary":"A guest can trigger a use-after-free in Cloud Hypervisor via duplicate virtio-block descriptors, potentially leading to code execution or denial of service.","user_interaction":"not_required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.9,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-416","name":"Use After Free"}],"description":"Cloud Hypervisor is a Virtual Machine Monitor for Cloud workloads. From version 21.0 to before version 51.2, a guest can cause a use-after-free in the cloud-hypervisor process by submitting two virtio-block descriptor chains that reuse the same head_index while asynchronous block I/O is enabled (e.g. io_uring, aio). When the kernel completes the duplicate operation before the original, the completion path frees a bounce buffer that the kernel is still actively reading from or writing to, corrupting the freed memory. This issue has been patched in versions 51.2 and 52.0.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cloud Hypervisor: Use-after-free in virtio-block Async I/O Completion","id":"CVE-2026-45782","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"use_after_free","year":"2026"},"n_packages":1,"n_references":5,"next":{"headline":"libp2p: Unvalidated PUT_VALUE records allow unbounded disk exhaustion on DHT server nodes","id":"CVE-2026-45783"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["52.0-1.1"],"introduced":["0"],"last_affected":[],"package":"cloud-hypervisor","purl":"pkg:rpm/opensuse/cloud-hypervisor\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10907-1"}],"prev":{"headline":"MCP Registry: OCI ownership validation fails open on upstream rate limits, allowing attacker-controlled package claims","id":"CVE-2026-45781"},"products":["cloud-hypervisor"],"published":"2026-06-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-06-10","vendors":["cloud-hypervisor"]},"summary":"A guest can trigger a use-after-free in Cloud Hypervisor via duplicate virtio-block descriptors, potentially leading to code execution or denial of service.","url":"https://insights.sbomify.com/CVE-2026-45782/"}