# CVE-2026-45782: Cloud Hypervisor: Use-after-free in virtio-block Async I/O Completion

> A guest can trigger a use-after-free in Cloud Hypervisor via duplicate virtio-block descriptors, potentially leading to code execution or denial of service.

- **Severity:** High 8.9 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jun 2026
- **Updated:** 10 Jun 2026
- **Also known as:** GHSA-f47p-p25q-83rh, openSUSE-SU-2026:10907-1

## What is CVE-2026-45782?

CVE-2026-45782 is a high-severity use after free vulnerability in cloud-hypervisor, published on 9 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Cloud Hypervisor is a Virtual Machine Monitor for Cloud workloads. From version 21.0 to before version 51.2, a guest can cause a use-after-free in the cloud-hypervisor process by submitting two virtio-block descriptor chains that reuse the same head_index while asynchronous block I/O is enabled (e.g. io_uring, aio). When the kernel completes the duplicate operation before the original, the completion path frees a bounce buffer that the kernel is still actively reading from or writing to, corrupting the freed memory. This issue has been patched in versions 51.2 and 52.0.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2026-45782?


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cloud-hypervisor` | openSUSE:Tumbleweed | All versions | 52.0-1.1 |

## How do I fix CVE-2026-45782?

Upgrade to a fixed version.

## Is CVE-2026-45782 being exploited?

There is no known exploitation of CVE-2026-45782 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45782 and fix it if it is affected.

What it is: CVE-2026-45782 is a high-severity use after free vulnerability in cloud-hypervisor, published on 9 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45782 in the wild and no public exploit code.

Affected product: cloud-hypervisor. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45782/ (Markdown: https://insights.sbomify.com/CVE-2026-45782/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45782
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45782
- OSV: https://osv.dev/vulnerability/CVE-2026-45782

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45782/
Summaries are generated and may contain mistakes; the official description above is the record.
