{"answers":{"affected":"2 open source packages ship an affected version, including @libp2p/kad-dht.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45783 exists.","fix":"Upgrade @libp2p/kad-dht to 16.2.6 or later.","what":"CVE-2026-45783 is a high-severity denial of service vulnerability in js-libp2p, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-45783 and fix it if it is affected.\n\nWhat it is: CVE-2026-45783 is a high-severity denial of service vulnerability in js-libp2p, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45783 exists.\n\nAffected packages and fixed versions:\n- @libp2p/kad-dht (npm): affected all versions; fixed in 16.2.6\n- @libp2p/kad-dht (npm): affected all versions; fixed in 16.2.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-45783/ (Markdown: https://insights.sbomify.com/CVE-2026-45783/index.md)","id":"CVE-2026-45783","markdown":"https://insights.sbomify.com/CVE-2026-45783/index.md","name":"CVE-2026-45783","record":{"aliases":["GHSA-32mq-hpph-xfvr"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"libp2p JavaScript library","requires_auth":"none","summary":"Remote attackers can exhaust disk space on libp2p DHT server nodes by sending unvalidated PUT_VALUE messages, causing denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"libp2p is a JavaScript Implementation of libp2p networking stack. Prior to version 16.2.6, an unauthenticated remote peer can exhaust the disk storage of any @libp2p/kad-dht node running in server mode by sending an unbounded stream of PUT_VALUE messages whose keys bypass all content validation. No credentials, no prior relationship, and no protocol deviation beyond a crafted key are required. The victim node's datastore fills until the host disk is exhausted, making the node unavailable. This issue has been patched in version 16.2.6.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"libp2p: Unvalidated PUT_VALUE records allow unbounded disk exhaustion on DHT server nodes","id":"CVE-2026-45783","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"rust-openssl: Potential out-of-bounds write in `CipherCtxRef::cipher_update_inplace` for AES-KW-PAD ciphers","id":"CVE-2026-45784"},"packages":[{"ecosystem":"npm","fixed":["16.2.6"],"introduced":["0"],"last_affected":[],"package":"@libp2p/kad-dht","purl":null,"source":"GHSA-32mq-hpph-xfvr"},{"ecosystem":"npm","fixed":["16.2.6"],"introduced":["0"],"last_affected":[],"package":"@libp2p/kad-dht","purl":"pkg:npm/%40libp2p/kad-dht","source":"GHSA-32mq-hpph-xfvr"}],"prev":{"headline":"Cloud Hypervisor: Use-after-free in virtio-block Async I/O Completion","id":"CVE-2026-45782"},"products":["js-libp2p"],"published":"2026-06-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-11","vendors":["libp2p"]},"summary":"Remote attackers can exhaust disk space on libp2p DHT server nodes by sending unvalidated PUT_VALUE messages, causing denial of service.","url":"https://insights.sbomify.com/CVE-2026-45783/"}